Temp files downloaded for helper apps never deleted

VERIFIED DUPLICATE of bug 63105

Status

SeaMonkey
General
--
major
VERIFIED DUPLICATE of bug 63105
17 years ago
13 years ago

People

(Reporter: Phil Peterson, Assigned: Scott MacGregor)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
Using 2001-06-15-04 commercial release build on WinNT

0. Clear out your temp directory, if it's cluttered
1. Go to http://www.amazon.com
2. Pick a CD and listen to a sample audio clip in Real Player
3. Close Real Player and close our application
4. Look in your temp directory

Expected: temp file deleted
Actual: temp files collect forever

FWIW, I believe the way this was done in 4.x is that we kept a list of temp
files in the Windows Registry which we deleted when quitting and launching (in
case of crash) the app. The point being that there wasn't a way to know when the
file was no longer needed -- maybe there is in the current code...
(Reporter)

Comment 1

17 years ago
Not sure if this is really a plugins bug or a file download bug. cc'ing law.
nominating for mozilla0.9.2 -- this seems like a bad bug to me.
Keywords: mozilla0.9.2

Comment 2

17 years ago
Not sure what category helper apps fall into. Reassigning to mscott
Assignee: av → mscott
Component: Plug-ins → Browser-General

Comment 3

17 years ago
Dup of Bug 63105?
(Reporter)

Comment 4

17 years ago

*** This bug has been marked as a duplicate of 63105 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 5

17 years ago
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.