Images with broken URL remain collapsed when SRC is reset to a correct URL

VERIFIED DUPLICATE of bug 22820

Status

()

Core
ImageLib
VERIFIED DUPLICATE of bug 22820
17 years ago
17 years ago

People

(Reporter: Wolfgang Schwarz, Assigned: Stuart Parmenter)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME)

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Unfortunately, Mozilla collapses images that could not be fetched and instead 
displays the ALT text inline, or nothing at all, if there is no ALT text (see 
bug 41924 and bug 75185).

When you change the image src of such a collapsed image to a correct URL using 
JavaScript, the correct image should be visible. But in fact, the image remains 
invisible.

This caused bug 67499, from where I take the testcase.
(Reporter)

Comment 1

17 years ago
Created attachment 38771 [details]
testcase
Over to imagelib.  This is a duplicate, but I can't find the original.
Assignee: karnaze → pavlov
Component: Layout → ImageLib
QA Contact: petersen → tpreston
Whiteboard: DUPEME

Comment 3

17 years ago

*** This bug has been marked as a duplicate of 22820 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 4

17 years ago
Veriried Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.