Last Comment Bug 862599 - Telemetry submission appears broken on Fx21
: Telemetry submission appears broken on Fx21
Status: RESOLVED WORKSFORME
:
Product: Toolkit
Classification: Components
Component: Telemetry (show other bugs)
: unspecified
: All All
: -- critical (vote)
: ---
Assigned To: Nathan Froyd [:froydnj]
:
: Georg Fritzsche [:gfritzsche]
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-16 16:33 PDT by Mike Connor [:mconnor]
Modified: 2013-07-02 07:59 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---
+
fixed


Attachments
backout bad commit from beta (bug 844331, attachment 730703) (3.26 KB, patch)
2013-04-17 14:01 PDT, Nathan Froyd [:froydnj]
nfroyd: review+
bajaj.bhavana: approval‑mozilla‑beta+
Details | Diff | Splinter Review
Submission Graphs (19.80 KB, application/force-download)
2013-04-23 15:46 PDT, "Saptarshi Guha[:joy]"
no flags Details
Telemetry Submission Counts by Channel (20.90 KB, application/pdf)
2013-04-29 12:10 PDT, "Saptarshi Guha[:joy]"
no flags Details

Description Mike Connor [:mconnor] 2013-04-16 16:33:21 PDT
Spun off from bug 844331, but I suspect that's the bug to be blamed.  Telemetry submissions on beta are way down since Fx21 shipped, starting on April 6th.  The patch backed out of Aurora yesterday was the patch blamed for breaking submissions, and since backed out numbers are recovering on Nightly, and apparently starting to recover on Aurora as well, that seems at least partially correct.  However, submissions on Aurora actually fell dramatically starting on March 30th, corresponding to the simpler version of the patch landing on Aurora mentioned in bug 844331 comment 34 and later.  That patch would have merged to Beta and started to hit users around April 6th, a couple of days after 21 Beta released.

At this point, it looks like we should back that change out of Beta.  There may be another cause, but that's the one that fits the data available.  Nightly/Aurora/Release all appear stable.
Comment 1 Nathan Froyd [:froydnj] 2013-04-17 14:01:19 PDT
Created attachment 738715 [details] [diff] [review]
backout bad commit from beta (bug 844331, attachment 730703 [details] [diff] [review])

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 844331
User impact if declined: None
Testing completed (on m-c, etc.): Similar patches have landed on nightly and aurora and significantly improved telemetry submission numbers.
Risk to taking this patch (and alternatives if risky): None.
String or IDL/UUID changes made by this patch: None.
Comment 2 Nathan Froyd [:froydnj] 2013-04-18 16:03:47 PDT
https://hg.mozilla.org/releases/mozilla-beta/rev/85fa17f2a405
Comment 3 Mike Connor [:mconnor] 2013-04-23 15:43:07 PDT
Saptarshi, can we verify that submissions are recovering here?
Comment 4 "Saptarshi Guha[:joy]" 2013-04-23 15:46:01 PDT
Created attachment 741068 [details]
Submission Graphs

In which channels? nightly looks like it's fixed(since 19th ish). Aurora,too is going upwards, Beta is still trending down.
Comment 5 Mike Connor [:mconnor] 2013-04-23 15:53:00 PDT
Ah, looks like we haven't shipped a beta since the day before the backout.  We'll have to come back to this after b4 ships to make sure this fixed it.
Comment 6 "Saptarshi Guha[:joy]" 2013-04-29 12:10:13 PDT
Created attachment 743210 [details]
Telemetry Submission Counts by Channel

Beta seems to be fixed, around 27-28th April.
Everything else seems a-okay. Green points indicate the submission count (given the prior history) is not out of whack.
Date as of 28th April.
Comment 7 Nathan Froyd [:froydnj] 2013-07-02 07:59:33 PDT
Closing, then.

Note You need to log in before you can comment on or make changes to this bug.