Closed Bug 862711 Opened 7 years ago Closed 7 years ago

[Music] Autoscan is not resumed, When Plug-Unplug USB Mass storage

Categories

(Firefox OS Graveyard :: Gaia::Music, defect)

ARM
Gonk (Firefox OS)
defect
Not set
critical

Tracking

(blocking-b2g:leo+, b2g18 fixed)

RESOLVED FIXED
1.1 QE2 (6jun)
blocking-b2g leo+
Tracking Status
b2g18 --- fixed

People

(Reporter: leo.bugzilla.gaia, Assigned: djf)

Details

(Whiteboard: [TD-8952] MiniWW)

1. Title : Music player doesn't displays all Music files,When usb mass storage connect - usb disconnect
2. Precondition : Have a couple of music files in internal and external memory
3. Tester's Action : 
		1.Have a couple of songs in internal memory and external memory ( have   different songs, just to distinguish)
		2.Set USB mode active on device
		3.Play any music file
		4.While music is playing, plug in the data cable.
		5.Music will stop with a popup, “unplug cable to play”
		6.When we unplug cable, player displays only the songs from internal                   memory (atleast in my case, I waited for some 3-5 mins, device dint update all available music files).
4. Detailed Symptom (ENG.) : After a USB connect-disconnect, Music player is not displaying all the files
5. Gaia Revision #:   
6. Expected : After a USB Connect-Disconnect, Music player should update the database and return the user all supported file list.
7.Reproducibility: Y
  1)Frequency Rate : 100%
8.Comparison Results : 
  1)Model Comparing : 
9. Attached files: 
   1)Log : 
   2)Test Contents : 
   3)Video file :
Whiteboard: [TD-8952]
Flags: needinfo?(dkuo)
Description updated,
STR:

1.Have a couple of songs memory 
2.Set USB mode active on device
3.Play any music file
4.While music is playing, plug in the data cable.
5.Music will stop with a popup, “unplug cable to play”
6.When we unplug cable, player doesn't display all the songs .
Update:

This issue can be only reproduced by using leo build, so I guess it might because our partner modified gonk or gecko themself. I will leave this to our parnter first cause I am not able to fix this without leo build.

leo.bugzilla.gaia@gmail.com, feel free to update here if you found the root cause or need further helps from me, thanks.
Flags: needinfo?(dkuo)
blocking-b2g: --- → leo?
Marking as blocking but POVB given comment 2.
blocking-b2g: leo? → leo+
Whiteboard: [TD-8952] → [TD-8952][POVB]
As discussed marking this for work week.
Flags: needinfo?(dflanagan)
Whiteboard: [TD-8952][POVB] → [TD-8952][POVB] MiniWW
I think this is the same underlying issue as bug 870327 and bug 875641: more fallout from the switch to allowing internal and external storage areas.

I only learned today that on devices with external and internal storage areas we allow the volumes to be shared independently.  So as in the case of those other bugs, if only one storage area is mounted for USB, the media apps don't receive the event they need.

I think I can fix this bug along with the other two.
Assignee: nobody → dflanagan
Flags: needinfo?(dflanagan)
Target Milestone: --- → 1.1 QE2 (6jun)
Hi David, given your comment 5 I think this bug then won't be a POVB (part of vendor build)?
Removing from whiteboard.
Whiteboard: [TD-8952][POVB] MiniWW → [TD-8952] MiniWW
This should be fixed by the patch that is awaiting review in bug 870327.
Bug 870327 has landed and has been uplifted, and that fixes this bug as well.

Currently there is a shortcoming in DeviceStorage where sharing via USB makes it look as if the sdcard has been removed. This will result in a complete rescan of all files (including metadata parsing) when the USB cable is unplugged.

Users who have a lot of media on their cards will find this inconvenient, but at least they will see the correct files.

Bug 878310 will address the underlying DeviceStorage issue and the problem will go away.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Flags: in-moztrap?
Added test case in MozTrap: 
https://moztrap.mozilla.org/manage/case/8517/
Flags: in-moztrap? → in-moztrap+
You need to log in before you can comment on or make changes to this bug.