Reader mode icon from the URL bar corner is almost impossible to access

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
6 years ago
3 years ago

People

(Reporter: paul.feher, Assigned: lucasr)

Tracking

23 Branch
ARM
Android
Points:
---

Firefox Tracking Flags

(firefox21 affected, firefox22 affected, firefox23 verified)

Details

(Whiteboard: ui-hackathon)

Attachments

(1 attachment)

Reporter

Description

6 years ago
Firefox for Android 21.0b3 (2013-04-16)
Aurora 22.0a2 (2013-04-17)
Nightly 23.0a1 (2013-04-17)
Devices: LG Nexus 4 (Android 4.2.2), Samsung Galaxy R (Android 2.3.4)

Steps to Reproduce:

1. Open a article on google.news.com
2. Tap on the reader mode icon in the URL bar corner to access the reader mode.

Expected:
The page should be displayed in reader mode.

Actual:
When you tap the reader mode icon, most of the times you access the awesome bar. Only after several tries the page is displayed in reader mode. This is very confusing and uncomfortable for the user.

Note:
Please see the video
http://youtu.be/8qi57J8vPPM
Please enable 'Show Touches' in the Android developer options and attach a screenshot of where you are tapping. This will help determine where you are tapping in correlation with the associated hit-point area.
Reporter

Comment 2

6 years ago
Posted image Contact_area
As you can see in the screen-shot attached the contact are is situated exactly over the reader mode icon.
This is the weirdest bug, I feel like one day it works, and the next day the icon is impossible to hit again. 

This is what the hit area should really look like for the reader icon. It should be really, really easy to touch. http://cl.ly/image/3y3M200g1n28
Sriram, didn't you fix this already? Any idea what the problem is now?
Flags: needinfo?(sriram)
Assignee

Comment 5

6 years ago
(In reply to Brian Nicholson (:bnicholson) from comment #4)
> Sriram, didn't you fix this already? Any idea what the problem is now?

AFAIK, sriram fixed the problem of mis-tapping on the tabs button because of the change on view stacking order in the toolbar. I guess we still need to grow the hit area for the stop/reader buttons.
(In reply to Lucas Rocha (:lucasr) from comment #5)
> (In reply to Brian Nicholson (:bnicholson) from comment #4)
> > Sriram, didn't you fix this already? Any idea what the problem is now?
> 
> AFAIK, sriram fixed the problem of mis-tapping on the tabs button because of
> the change on view stacking order in the toolbar. I guess we still need to
> grow the hit area for the stop/reader buttons.

Yes, I still have a really hard time hitting the reader mode icon.
Assignee

Updated

6 years ago
Whiteboard: ui-hackathon
Assignee

Comment 7

6 years ago
FYI: I'm fixing this as part bug 858687.
Assignee

Updated

6 years ago
Assignee: nobody → lucasr.at.mozilla
Assignee

Comment 9

6 years ago
This was fixed with: https://hg.mozilla.org/mozilla-central/rev/08dec3bd99a0
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(sriram)
Resolution: --- → FIXED
Status: RESOLVED → VERIFIED
Lucas, can we uplift this to beta? I can't get into reader mode at all on my Nexus 4 on Beta.
tracking-fennec: --- → ?
Flags: needinfo?(lucasr.at.mozilla)
Assignee

Comment 11

6 years ago
(In reply to Kartikaya Gupta (email:kats@mozilla.com) from comment #10)
> Lucas, can we uplift this to beta? I can't get into reader mode at all on my
> Nexus 4 on Beta.

The patch that fixed this bug was part of a major refactoring in the toolbar's layout/code. I could try to produce a simpler fix but might still be too risky for beta.
Flags: needinfo?(lucasr.at.mozilla)
tracking-fennec: ? → ---
You need to log in before you can comment on or make changes to this bug.