there's no marketplace icon

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: willkg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

I updated to the 20130416070203 build and there is no longer a marketplace icon on any of the homescreen pages.

OS: 1.1.0.0-prerelease
Platform: 18.0
Build id: 20130416070203
Channel: Beta
Git: 2013-04-12 15:18:07 f8e8f2b

Updated

5 years ago
Blocks: 815411
I just updated to 20130417070204 and the marketplace icon is in the homescreen again.

Marking this FIXED.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
OS: Linux → All
Hardware: x86 → All
Resolution: --- → FIXED

Updated

5 years ago
No longer blocks: 815411
Axel also confirmed he hit this issue. Reopening for investigation.
Blocks: 863032
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
two confirmed reproductions. Something is definitely going wrong here.

tef? nom.
blocking-b2g: --- → tef?
Since the marketplace will be a packaged app for new users, this upgrade scenario (while bad!) doesn't warrant tef+.

Let's investigate this regardless.
blocking-b2g: tef? → -
(In reply to Andrew Overholt [:overholt] from comment #4)
> Since the marketplace will be a packaged app for new users, this upgrade
> scenario (while bad!) doesn't warrant tef+.

The root cause of the tef? nom isn't about the marketplace issue in this case. It's about the fact that we can have OTA updates that cause a preinstalled app to completely disappear unintentionally. Operating under the safety that "we will never change our preinstalled apps on device" by an OTA update is a bad idea, as we've seen with related bugs. There's a problem going on here with OTA update flow with preinstalls that needs investigation and a fix. Back to nom on that basis.
blocking-b2g: - → tef?

Comment 6

5 years ago
here's the last update logs with dates:


root@android:/data/local/updates # ls -l
drwxr-x--- root     root              2013-04-17 21:53 0
-rw-r----- root     root        13266 2013-04-07 16:16 backup-update.log
-rw-rw-rw- root     root        13475 2013-04-17 21:53 last-update.log

I seem to have two local installs of marketplace:

root@android:/system/b2g/webapps # ls -la marketplace                          
-rw-r--r-- root     root         9361 2013-04-07 16:15 manifest.webapp
root@android:/system/b2g/webapps # ls -la marketplace.firefox.com/
-rw-r--r-- root     root         7576 2013-04-17 21:52 application.zip
-rw-r--r-- root     root         9360 2013-04-17 21:52 update.webapp

Comment 7

5 years ago
FWIW, I saw the same as comment #0 and comment #1 with those two builds. Gone with the 16th build, back on the 17th build.
I'll hold on noming and talk to Andrew directly about this.
blocking-b2g: tef? → ---
Talked with Andrew about this - the best resolution to do here is to at least investigate what happened during the OTA update from 15th to 16th that would cause this. If it's a bigger underlying issue, then it might be worth noming.

Fabrice - When you get the chance, let's dig into this.
Flags: needinfo?(fabrice)
Axel is right.  the bug does have to do with the specific builds.

The name of the app was wrong in the 4/7 build.  You can also see a change in the look of the icon.

I checked an earlier build : 
2013-03-03-07-02-02:
/system/b2g/webapps
marketplace.firefox.com

Then I checked the 4/7 build without updating to it:
2013-04-07-07-02-04:
/system/b2g/webapps
marketplace

After updating from the 4/7 to the 4/17 build, 
2013-04-17-07-02-04 from OTA:
I get 2 marketplace icons:
marketplace
marketplace.firefox.com

Thanks for getting that info in here Pike.  I can replicate the double icon issue.  Trying to see if I can duplicate the no icon issue.

Comment 11

5 years ago
Note, I updated the phone with 20130418070205, and the marketplace is there and works.

I bet it's more something about "breaking on first update, fixed on second" than anything else.

Updated

5 years ago
Duplicate of this bug: 868861
Maybe related/dupe from bug 834123?
We haven't seen this happen after we did the permanent move to a packaged app. Given that rationale, I'm going to close this as a wont fix, but the root cause is something we should watch out for in the future.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Flags: needinfo?(fabrice)
Resolution: --- → WONTFIX

Updated

5 years ago
No longer blocks: 863032
You need to log in before you can comment on or make changes to this bug.