The "Ringer & Notifications"/"Alarm"/"Brightness" sliders in the "Sound" and "Display" Settings screens should not have a red highlight/border

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
8 months ago

People

(Reporter: jwatt, Assigned: jwatt)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

6 years ago
I'm just filing this to try and avoid having anyone spend time debugging this. This is actually a gecko bug, and not a bug in B2G. It will be fixed in bug 853525.
(Assignee)

Updated

6 years ago
Summary: The thumb of the sliders in the "Sound" and "Display" Settings screens should not have a red highlight/border → The "Ringer & Notifications"/"Alarm"/"Brightness" sliders in the "Sound" and "Display" Settings screens should not have a red highlight/border
adding swilkes and jachen so that they are aware that this is a gecko bug.

Comment 3

6 years ago
Thanks Naoki!
(Assignee)

Comment 4

6 years ago
Some background: this is caused by rounding error that makes the <input type=range> think that it has a step mismatch. The red highlight is to indicate that error state, and comes from this rule I believe:

http://mxr.mozilla.org/mozilla-central/source/layout/style/forms.css?rev=434c6e694813&mark=644-646#641

If you don't want to wait for bug 853525 to be fixed, you could override that rule as appropriate.

Another way to work around this bug would be to add step=any to the <input type=range> elements...if that's appropriate. In fact maybe some/all of them should have that in any case?
(Assignee)

Comment 5

5 years ago
Fixed by bug 853525.

Comment 6

8 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 8 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.