Closed Bug 862841 Opened 9 years ago Closed 9 years ago

server status cron must get info from different source

Categories

(Socorro :: Backend, task)

x86_64
Linux
task
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: lars, Assigned: lars)

References

Details

(Whiteboard: [qa-])

the server status cron reports on queuing data from the jobs table.  Because the new processor is aggressive about cleaning up the jobs table, the status cron misses seeing some queue status.  

rework the server status crons to query the reports table instead for the information that it used to get from the jobs table.
Duplicate of this bug: 860960
Commit pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/033fa73649ec61349948954928a29d58dc034c5b
Merge pull request #1191 from twobraids/status_cron

Fixes Bug 862841: moved queries to reports table from jobs table
Status: NEW → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
Landed on stage and moved into 41. We have limited visibility into the back end without the cron_status or statsd. I'd like to get one of them back ASAP and this is ready to go.
Whiteboard: [qa-]
Target Milestone: 42 → 41
Whiteboard: [qa-]
whoops, 42 already shipped
Target Milestone: 41 → 42
You need to log in before you can comment on or make changes to this bug.