Closed Bug 862929 Opened 9 years ago Closed 9 years ago

ANRReporter sometimes cannot find end of the Fennec stack trace

Categories

(Firefox for Android Graveyard :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

(firefox22 fixed)

RESOLVED FIXED
Firefox 23
Tracking Status
firefox22 --- fixed

People

(Reporter: jchen, Assigned: jchen)

References

Details

Attachments

(1 file)

There's a mistake in logic in the fix for bug 845416, which results in the ANR report not cutting off at the end of the Fennec stack trace
The new logic better handles when the end of stack marker spans across two chunks of data.
Attachment #738798 - Flags: review?(blassey.bugs)
Attachment #738798 - Flags: review?(blassey.bugs) → review+
Comment on attachment 738798 [details] [diff] [review]
Find end of ANR trace the correct way (v1)

[Approval Request Comment]

Bug caused by (feature/regressing bug #): Bug 845416

User impact if declined: Mostly a privacy concern. Without this fix, ANR reports sometimes can include stack traces outside of Fennec (e.g. stacks of the system process)

Testing completed (on m-c, etc.): Locally

Risk to taking this patch (and alternatives if risky): Very small; fix only touches the case when we could include other stacks in ANR reports

String or IDL/UUID changes made by this patch: None
Attachment #738798 - Flags: approval-mozilla-aurora?
Comment on attachment 738798 [details] [diff] [review]
Find end of ANR trace the correct way (v1)

:nchen,Please add qawanted if we need help with verification on branches once this lands or mark this bug verified if you can help with verification here.
Attachment #738798 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/8aab5521a29f
Status: ASSIGNED → RESOLVED
Closed: 9 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 23
Product: Firefox for Android → Firefox for Android Graveyard
You need to log in before you can comment on or make changes to this bug.