WebSMS Android backend: guard all WebSMS code with MOZ_WEBSMS_BACKEND

RESOLVED DUPLICATE of bug 859616

Status

()

Core
DOM: Device Interfaces
RESOLVED DUPLICATE of bug 859616
5 years ago
5 years ago

People

(Reporter: vicamo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Comment hidden (empty)
Vicamo, I think we are planning to no longer use MOZ_WEBSMS_BACKEND. Brad, is that correct?
(Reporter)

Comment 2

5 years ago
(In reply to Mounir Lamouri (:mounir) (mostly away until 12th June) from comment #1)
> Vicamo, I think we are planning to no longer use MOZ_WEBSMS_BACKEND. Brad,
> is that correct?

Could you outline a little bit more on the planning solutions, so that we can amend this bug into the thing you prefer?

The original problem here is somehow WebSMS Android backend code still gets built in FirefoxOS b2g18 branch tbpl.  With --enable-websms-backend option, we can temporarily disables WebSMS API on Fennec, land features needed for FirefoxOS and come back for TODOs blocking bug 862715.
Flags: needinfo?(mounir)
Flags: needinfo?(blassey.bugs)
Bug 860067 would allow us to ship WebSMS support to Android, but I don't know why we wouldn't keep the flag as a kill switch, at least temporarily.
Flags: needinfo?(blassey.bugs)
Why not simply have the about:config flag to enable/disable the feature? A compile flag is hard to maintain and doesn't give us much benefit if we anyway get the permission added to another app/service.
Flags: needinfo?(mounir)
(Reporter)

Comment 5

5 years ago
(In reply to Mounir Lamouri (:mounir) from comment #4)
> Why not simply have the about:config flag to enable/disable the feature? A
> compile flag is hard to maintain and doesn't give us much benefit if we
> anyway get the permission added to another app/service.

Based on bug 859616, we should return undefined for platforms doesn't support WebSMS.  So we have to keep all WebSMS related code inside MOZ_WEBSMS_BACKEND.

This bug actually duplicates bug 859616, which will basically guard *all* WebSMS code with MOZ_WEBSMS_BACKEND.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 859616
You need to log in before you can comment on or make changes to this bug.