Closed Bug 863278 Opened 10 years ago Closed 10 years ago

set aside 2 mac build machines for servo builds

Categories

(Release Engineering :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: bhearsum, Assigned: bhearsum)

References

Details

Attachments

(2 files)

These will be separated from the main pool of machines and need to have their keys removed, passwords changed, etc. Hopefully we'll be able to puppet our way to all of this.
Looks like neither passwords nor keys are puppet managed on bld-lion-r5 machines. All we need to do here is pick a couple of machines, clean out their buildslave dir, and repoint them in slavealloc.
Depends on: 760093
Going to use bld-lion-r5-095 and 096 for this. Dustin is using 096 to work on bug 760093 right now.
Attachment #742444 - Flags: review?(catlee)
Attachment #742445 - Flags: review?(catlee)
Depends on: 866212
Attachment #742445 - Flags: review?(catlee) → review+
Attachment #742444 - Flags: review?(catlee) → review+
Attachment #742445 - Flags: checked-in+
Comment on attachment 742444 [details] [diff] [review]
remove them from old puppet

Updated scl3-production-puppet.
Attachment #742444 - Flags: checked-in+
In production
Depends on: 870340
When the DNS zones and DHCP bits are correctly generated, these should be renamed as follows:

bld-lion-r5-095 -> servo-lion-r5-001.build.servo.releng.scl3.mozilla.com 10.26.80.21
bld-lion-r5-096 -> servo-lion-r5-002.build.servo.releng.scl3.mozilla.com 10.26.80.22
(In reply to Amy Rich [:arich] [:arr] from comment #7)
> When the DNS zones and DHCP bits are correctly generated, these should be
> renamed as follows:
> 
> bld-lion-r5-095 -> servo-lion-r5-001.build.servo.releng.scl3.mozilla.com
> 10.26.80.21
> bld-lion-r5-096 -> servo-lion-r5-002.build.servo.releng.scl3.mozilla.com
> 10.26.80.22

I updated inventory with these changes - both the name of the host + the key/value store.
Depends on: 873460
These machines are connected to the master now. If we need script changes or buildbot master config changes to make the builds work I'll file a new bug.
Status: NEW → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Product: mozilla.org → Release Engineering
Component: General Automation → General
You need to log in before you can comment on or make changes to this bug.