crash in js::Debugger::parseResumptionValue

RESOLVED DUPLICATE of bug 858170

Status

()

Core
JavaScript Engine
--
critical
RESOLVED DUPLICATE of bug 858170
5 years ago
5 years ago

People

(Reporter: GPHemsley, Unassigned)

Tracking

({crash, regression})

22 Branch
All
Mac OS X
crash, regression
Points:
---

Firefox Tracking Flags

(firefox21 unaffected, firefox22 affected, firefox23 unaffected)

Details

(crash signature)

(Reporter)

Description

5 years ago
This bug was filed from the Socorro interface and is 
report bp-ed3b5d55-cf5b-460e-b5b3-11caa2130418 .
============================================================= 

I've had this crash twice in a row now (the other crash is bp-3f53d761-291a-4d45-98aa-2f6b22130418), so it's probably easily reproduceable, but I don't quite know how.

All I know is that I was messing with setting breakpoints and refreshing the page. I may have set breakpoints at the beginning and/or end of a file. Workers were involved, but I don't know if that's relevant.
CCing the experts.
Assignee: nobody → general
Component: Developer Tools: Debugger → JavaScript Engine
Product: Firefox → Core

Comment 2

5 years ago
It first showed up in 22.0a1/20130319 and stopped after 23.0a1/20130404. The working range is:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=c232bec6974d&tochange=55f9e3e3dae7
status-firefox21: --- → unaffected
status-firefox22: --- → affected
status-firefox23: --- → unaffected
Keywords: regression
Version: 20 Branch → 22 Branch
fireNewScript on the stack. This must be a duplicate of bug 858170, which was fixed on April 4.

Not sure why the working range in comment 2 seems to be off by one though.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 858170
You need to log in before you can comment on or make changes to this bug.