Allow Bouncer to store and use internal redirect rules

RESOLVED FIXED

Status

Webtools
Bouncer
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: brandon, Assigned: brandon)

Tracking

Trunk
x86
Mac OS X
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Assignee)

Description

5 years ago
From time to time we receive a request to have a particular version of Firefox be redirected to a later version for a specific platform.

We should allow users of Bouncer to create rules that specify what to do in certain cases.

For example, users should be able to say:

If:
Product: X
Platform: Y
Then: redirect to product Z

Bouncer should then be smart enough to check for rules matching known values, and interpret the action to take properly.
(Assignee)

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Duplicate of this bug: 801208
Brandon, I just finished testing this API now that bug 922281 is fixed. As far as I can tell it's working fine and will meet our needs for automating the updates. Ship it!
You need to log in before you can comment on or make changes to this bug.