[Buri][Beetle lite FF][First time experience]There no prompt when page loading

RESOLVED DUPLICATE of bug 911752

Status

Firefox OS
Gaia::First Time Experience
P2
normal
RESOLVED DUPLICATE of bug 911752
5 years ago
4 years ago

People

(Reporter: sync-1, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:-, b2g18+ wontfix)

Details

Attachments

(4 attachments)

(Reporter)

Description

5 years ago
SW123
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.077
 Firefox os  v1.0.1
 Mozilla build ID:20130414070204
 
 
 +++ This bug was initially created as a clone of Bug #442566 +++
 
 Created an attachment (id=393536)
 caputer
 
 DEFECT DESCRIPTION:
 [First time experience]There no prompt when page loading
  REPRODUCING PROCEDURES:
 1.Download version then first power on
 2.Enter First time experience to check "Your privacy",tap B2G OS/Marketplace/everything.me, there display black space, no prompt when page loading, please check the attachment
 
  EXPECTED BEHAVIOUR:
 There should be have a prompt when page loading(ex:loading)
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 5/5
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #442566 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

5 years ago
Clone from brother
(Reporter)

Comment 2

5 years ago
Created attachment 739395 [details]
caputer1

Clone from brother
(Reporter)

Comment 3

5 years ago
Clone from brother
(Reporter)

Comment 4

5 years ago
Created attachment 739396 [details]
caputer

Clone from brother

Comment 5

5 years ago
Is there any body know who is familiar with ftu??
The wifi prompt (when searching for networks) was added on master and v1-train on bug 811149.

But so far we don't have any loading prompt for when loading external webpages. Maybe some feedback from UX would be useful.
Flags: needinfo?(jcarpenter)

Comment 7

5 years ago
Dear Fernando:
The commit as follow for 811149:
Uplifted commit 7d6c46344f6f89bc4b7232450bf5cdce8ba30982 as:
v1-train: 4846f80b313b241431c4842114287e1edc036051
can be merged into v1.0.1 ??
(In reply to buri.blff from comment #7)
> Dear Fernando:
> The commit as follow for 811149:
> Uplifted commit 7d6c46344f6f89bc4b7232450bf5cdce8ba30982 as:
> v1-train: 4846f80b313b241431c4842114287e1edc036051
> can be merged into v1.0.1 ??

If you think that the bug should be fixed also on v1.0.1, you can set the corresponding tracking flag (status-b2g18-v1.0.1: affected) on bug 811149, and if considered proper, will be uplifted
Yes, we should display a loading indicator on this page. The same one we use with window.open would be appropriate. Adding Eric Pang for needsinfo on the right indicator to use in this instance.
Flags: needinfo?(jcarpenter) → needinfo?(epang)
Created attachment 744862 [details]
Loading Gifs

I've attached the loading gif, which should be positioned under the headers.  I've also included an example of how it's used in the browser app.  Let me know if you have any questions.  Thanks!
Flags: needinfo?(epang)

Comment 11

5 years ago
Dear Eric Pang:
   can your give me your commit number? So i can check if the patch has been landed on v1.0.1
(In reply to buri.blff from comment #11)
> Dear Eric Pang:
>    can your give me your commit number? So i can check if the patch has been
> landed on v1.0.1

Hi, my attachment wasn't a patch, it's the loading image asset that should be used in implementation :). Thanks!
Asking tef? because the partners seem to want this on 1.0.1. An implementation exists in Bug 811149 for the WiFi page but this bug is for the external-link-loader page (which loads any external url, like the privacy page).
blocking-b2g: --- → tef?

Updated

5 years ago
Whiteboard: [tef-triage]
Flags: needinfo?(lsblakk)

Comment 14

5 years ago
Dear Julien:
     Is there anybody response for browser. We has add prompt to wifi screen. But the privacy page need external-link-loader page, i think this bug is of browser.

Comment 15

5 years ago
we has resolve this bug. pleas close it, thanks.

Updated

5 years ago
blocking-b2g: tef? → ---
Flags: needinfo?(lsblakk)
I'm kinda lost right now. Is this solved or not? I didn't see any patch, and I still can repro on all versions.

Comment 17

5 years ago
I resolved in our owner code.
I still think we should do that at one point.

buri.blff> care to contribute your code with us ?
blocking-b2g: --- → leo?
tracking-b2g18: --- → ?
Flags: needinfo?(buri.blff)

Comment 19

5 years ago
I am happy to contribute our code.  I will add my patch by github. Hope your review.
Flags: needinfo?(buri.blff)
Please add an attachment here and request review on it :)

Comment 21

5 years ago
Created attachment 750235 [details]
The patch and resource for 863536

Dear felash:
    Hope your review, thanks.
Attachment #750235 - Flags: review?(felash)
Attachment #750235 - Attachment is patch: false
Attachment #750235 - Attachment mime type: text/plain → application/x-gzip
Comment on attachment 750235 [details]
The patch and resource for 863536

It gives me the error 'corrupt patch on line 149'.

Has anyone make this work?
Hey buri.blff ...could you please attach the patch directly, or use github for a pull request and add the url here?

A tar file is not the best idea, plus is not working properly.

Thanks
Flags: needinfo?(buri.blff)

Comment 24

5 years ago
yes, i will give a new patch to gihub.
Flags: needinfo?(buri.blff)
Comment on attachment 750235 [details]
The patch and resource for 863536

removing the review flag until we get a correct patch.
Attachment #750235 - Flags: review?(felash)

Updated

5 years ago
Whiteboard: [tef-triage]
buri, still waiting for your github pull request.
Flags: needinfo?(buri.blff)
Tracking, please nominate for uplift when ready and we can evaluate risk of landing to branch.
blocking-b2g: leo? → -
status-b2g18: --- → affected
tracking-b2g18: ? → +
we use window.open directly now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 911752
Flags: needinfo?(buri.blff)
status-b2g18: affected → wontfix
You need to log in before you can comment on or make changes to this bug.