Intermittent layout/reftests/bugs/28811-1a.html,28811-2a.html,28811-2b.html,359903-2.html | image comparison (==), max difference: 1, number of differing pixels: 4

RESOLVED FIXED in Firefox 29

Status

()

defect
RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: emorley, Assigned: tnikkel)

Tracking

({intermittent-failure})

Trunk
mozilla30
x86
Windows XP
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox28 wontfix, firefox29 fixed, firefox30 fixed, firefox-esr24 fixed, b2g-v1.3 fixed, b2g-v1.3T fixed, b2g-v1.4 fixed, b2g-v2.0 fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Rev3 WINNT 5.1 mozilla-inbound debug test reftest on 2013-04-18 21:26:05 PDT for push aa774ab6eb72

slave: talos-r3-xp-047

https://tbpl.mozilla.org/php/getParsedLog.php?id=21993464&tree=Mozilla-Inbound

{
21:40:35     INFO -  REFTEST TEST-START | file:///c:/talos-slave/test/build/tests/reftest/tests/layout/reftests/bugs/28811-2-ref.html | 1650 / 9242 (17%)
21:40:35     INFO -  ++DOMWINDOW == 222 (09DBCCB0) [serial = 4301] [outer = 076C5810]
21:40:36     INFO -  ++DOCSHELL 073814F0 == 6 [id = 14]
21:40:36     INFO -  ++DOMWINDOW == 223 (07381CC0) [serial = 4302] [outer = 00000000]
21:40:36     INFO -  WARNING: NS_ENSURE_TRUE(NS_SUCCEEDED(rv) && subjPrincipal) failed: file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/docshell/base/nsDocShell.cpp, line 8287
21:40:36     INFO -  WARNING: Subdocument container has no frame: file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/layout/base/nsDocumentViewer.cpp, line 2388
21:40:36     INFO -  ++DOMWINDOW == 224 (07631480) [serial = 4303] [outer = 07381CC0]
21:40:36     INFO -  REFTEST TEST-UNEXPECTED-FAIL | file:///c:/talos-slave/test/build/tests/reftest/tests/layout/reftests/bugs/28811-2a.html | image comparison (==), max difference: 1, number of differing pixels: 4
}
Comment hidden (Legacy TBPL/Treeherder Robot)
Summary: Intermittent layout/reftests/bugs/28811-2a.html | image comparison (==), max difference: 1, number of differing pixels: 4 → Intermittent layout/reftests/bugs/28811-2a.html,28811-2b.html | image comparison (==), max difference: 1, number of differing pixels: 4
Comment hidden (Legacy TBPL/Treeherder Robot)
Duplicate of this bug: 865528
Summary: Intermittent layout/reftests/bugs/28811-2a.html,28811-2b.html | image comparison (==), max difference: 1, number of differing pixels: 4 → Intermittent layout/reftests/bugs/28811-1a.html,28811-2a.html,28811-2b.html,359903-2.html | image comparison (==), max difference: 1, number of differing pixels: 4
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(Reporter)

Updated

6 years ago
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Comment hidden (Legacy TBPL/Treeherder Robot)
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Comment hidden (Legacy TBPL/Treeherder Robot)
(Assignee)

Comment 17

6 years ago
(In reply to TBPL Robot from comment #16)
> RyanVM
> https://tbpl.mozilla.org/php/getParsedLog.php?id=27582728&tree=Mozilla-
> Inbound
> Windows XP 32-bit mozilla-inbound debug test reftest on 2013-09-09 08:44:47
> revision: 486b61c42838
> slave: t-xp32-ix-088
> 
> REFTEST TEST-UNEXPECTED-FAIL |
> file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/28811-
> 2b.html | image comparison (==), max difference: 255, number of differing
> pixels: 19

This is a totally different failure more. It's not the image that's differing. The text looks like it's leaking outside of the iframe. That's a weird bug as the text should definitely be clipped to the iframe.
Definitely not the same bug. I filed bug 914474, as I got the same on my latest m-c push.
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 19

6 years ago
A different occurrence was the reason we re-opened this actually, so no need to mark as works for me.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Comment hidden (Legacy TBPL/Treeherder Robot)
(Assignee)

Comment 21

6 years ago
(In reply to TBPL Robot from comment #20)
> Tomcat
> https://tbpl.mozilla.org/php/getParsedLog.php?id=27701506&tree=Mozilla-
> Inbound
> Windows XP 32-bit mozilla-inbound opt test reftest on 2013-09-11 06:59:46
> revision: 42a4dec61095
> slave: t-xp32-ix-129
> 
> REFTEST TEST-UNEXPECTED-FAIL |
> file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/28811-
> 2a.html | image comparison (==), max difference: 255, number of differing
> pixels: 27
> REFTEST TEST-UNEXPECTED-FAIL |
> file:///C:/slave/test/build/tests/reftest/tests/layout/reftests/bugs/28811-
> 2b.html | image comparison (==), max difference: 255, number of differing
> pixels: 27

This is the text failure mode and not the image failure mode again.
(Assignee)

Comment 22

6 years ago
I think I understand the failure mode where a few pixels in one of the images are 1 off.

If the images load and decode slightly later then the resulting invalidation will cover a portion of the page that covers the images only. As opposed to the images being decoding when the page is first drawn. On d3d9 we create a surface the size of the invalid area that we need to draw and draw into it. So this means that the image to user space transform is different if we are drawing to a smaller surface that only includes the images and not the whole page. cairo does some fiddling with the matrix too in order to feed it into pixman, and we might not hit this is cairo didn't do so much fiddling. In any case the ideal coordinate to sample in the bilinear scale lands exactly on a half pixel, so one tiny change to any floating point number involved and we sample four different pixels and get a different result.

This test does not appear to have anything to do with the details of image scaling, so I think it's safe to replace the image in the test with a solid color image so this does not cause a failure.

The patches in bug 847223 make this happen a lot more frequently, hence we it needs to be solved.
Blocks: 847223
(Assignee)

Comment 23

6 years ago
Assignee: nobody → tnikkel
Attachment #803501 - Flags: review?(jmuizelaar)
(Assignee)

Updated

6 years ago
Component: DOM: Core & HTML → Graphics
(Reporter)

Comment 24

6 years ago
Thank you for looking at this! :-)
Comment on attachment 803501 [details] [diff] [review]
replace the image with solid blue

Review of attachment 803501 [details] [diff] [review]:
-----------------------------------------------------------------

Seems reasonable.
Attachment #803501 - Flags: review?(jmuizelaar) → review+
https://hg.mozilla.org/mozilla-central/rev/9afc5c57e414
Status: REOPENED → RESOLVED
Last Resolved: 6 years ago6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla26
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment hidden (Legacy TBPL/Treeherder Robot)
(Assignee)

Comment 40

5 years ago
I don't know why the 359903 failure was included in this bug, it doesn't look related at all. And given that it has started a recent trend of showing up a lot we should probably split it out.
Pretty sure you weren't trying to test pixel-consistent painting of resized gifs on mobile devices, either.
Attachment #8390561 - Flags: review?(bzbarsky)
Comment hidden (Legacy TBPL/Treeherder Robot)
Comment on attachment 8390561 [details] [diff] [review]
and your little dog 359903-2, too

r=me
Attachment #8390561 - Flags: review?(bzbarsky) → review+
Comment hidden (Legacy TBPL/Treeherder Robot)
You need to log in before you can comment on or make changes to this bug.