APN Settings: automatic configuration does not work for MVNO users

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
6 years ago
7 months ago

People

(Reporter: kaze, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
Steps to reproduce:
 • use an FxOS device with a *new* SIM card
 • Settings > Cellular & Data > Data settings
 • see the list of APN presets matching the current SIM card

Expected result:
 • the APN preset matching the current SIM card is selected

Actual result:
 • the *first* APN preset matching the current SIM card is selected

At the moment we only rely on the MCC/MNC tuple to filter all “compatible” APN presets. This is fine in most cases because there’s usually only one operator per MCC/MNC tuple, but it can be an issue for some operators, especially with MVNOs.

As an example, 208/10 matches SFR and all the related MVNOs (NRJ, Coriolis, Keyyo…). So if a user puts a Keyyo SIM card into an FxOS phone, the default APN settings will be the ones corresponding to SFR — which will probably not work.

We should use the SPN info (which is also stored in the SIM card, along with MCC/MNC) and compare it with the “compatible” carrier names to pre-select the most likely APN preset. This should be enough for most MVNO users.

http://mxr.mozilla.org/mozilla-central/source/dom/network/interfaces/nsIDOMMobileConnection.idl#496
(Reporter)

Updated

6 years ago
Duplicate of this bug: 863677
MVNO situation is very complex

Comment 3

7 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 7 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.