Missing events (e.g. ondatachannel) when running datachannel tests

RESOLVED FIXED

Status

()

Core
WebRTC
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({regression})

23 Branch
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-automation-blocked])

Attachments

(2 attachments)

(Assignee)

Description

5 years ago
Created attachment 739545 [details]
non-working mochitest

When running the following mochitest you will notice that no ondatachannel events are getting fired even with data connection successfully established. Having the exact same code in a standalone test it works fine.

We are blocked with the creation of any datachannel related test. Bug 796894 is the most important one here because it will get an update for the framework too. 

I will investigate what's causing this now.
(Assignee)

Comment 1

5 years ago
Created attachment 739547 [details]
testcase (standalone)

Same code as a standalone testcase.
(Assignee)

Comment 2

5 years ago
So the reason here is not mochitest vs. standalone, but the version of the build. While the mochitest was running on latest m-c I had a Nightly build from two days ago. This build doesn't contain the first patch as landed on bug 862744 later. After upgrading Nightly to yesterdays version the standalone testcase is also broken.

The follow-up fix on bug 862744 might help us here. I will retest in a bit after the current build is done.
Blocks: 862744
Keywords: regression
(Assignee)

Comment 3

5 years ago
Once bug 862744 is fixed it will work. Additionally to this I noticed an exception thrown inside of the ondatachannel event listener because I reference to this instead of self.

Lets wait for the landing of the second patch on bug 862744 in mozilla-central. Then we are unblocked!
Summary: Missing events (e.g. ondatachannel) when running tests with mochitest → Missing events (e.g. ondatachannel) when running datachannel tests
Per IRC, invalid
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
(Assignee)

Comment 5

5 years ago
No, this is not invalid. The main reason for this broken behavior was the regression introduced by the patch on bug 862744. This is fixed now.
Resolution: INVALID → FIXED
You need to log in before you can comment on or make changes to this bug.