crash in js::ion::MarkActiveBaselineScripts when toggling Multi-thread profiling

RESOLVED WONTFIX

Status

()

defect
--
critical
RESOLVED WONTFIX
6 years ago
10 months ago

People

(Reporter: BenWa, Unassigned)

Tracking

({crash})

Trunk
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-5dc92e21-ee1b-4dc3-adff-7f8d42130419 .
=============================================================
Please be more specific: steps to reproduce, conditions...
Version: unspecified → Trunk
STR:
1) Make sure you have the latest addon install from github:
https://github.com/bgirard/Gecko-Profiler-Addon/raw/master/geckoprofiler.xpi
2) Stop the profiler, select 'Threads'
3) Toggle the profiler while you have webworkers active. Hitting 'analyze' will spawn web workers.

Until bug 863468 is fixed 'Threads' is forced on so we should get a higher volume of this crash today. I'm aiming to land bug 863468 in time for the next nightly in which case this bug will only affect people opting-in this new profiler feature.
Assignee: general → nobody
Crash Signature: [@ js::ion::MarkActiveBaselineScripts(JS::Zone*)] → [@ js::ion::MarkActiveBaselineScripts(JS::Zone*)] [@ js::ion::MarkActiveBaselineScripts]
Closing because no crash reported since 12 weeks.
Status: NEW → RESOLVED
Closed: 10 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.