Closed Bug 863932 Opened 7 years ago Closed 7 years ago

[B2G][Leo][Lockscreen][Camera] Camera does not work from lockscreen with passcode

Categories

(Firefox OS Graveyard :: Gaia::System::Lockscreen, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(blocking-b2g:koi+, b2g18 unaffected, b2g18-v1.0.0 unaffected, b2g18-v1.0.1 unaffected, b2g-v1.2 verified)

RESOLVED FIXED
blocking-b2g koi+
Tracking Status
b2g18 --- unaffected
b2g18-v1.0.0 --- unaffected
b2g18-v1.0.1 --- unaffected
b2g-v1.2 --- verified

People

(Reporter: sparsons, Assigned: gduan, NeedInfo)

Details

(Keywords: regression, Whiteboard: leorun1)

Attachments

(1 file)

Description:
An error message will appear prompting the user to insert a memory card in order to use the camera even though the memory card is already inserted, while screen is locked with a passcode. User will be able to use camera normally once they enter the passcode.

Repro Steps:
1) Updated to Leo Build ID: 20130411070205
2) Enter Settings, enable passcode.
3) Lock Phone.
4) Press the power button to wake up the phone.
5) Instead of unlocking, select the camera. 

Actual:
Message appears prompting user to insert memory card even though one is already inserted. They will not be able to access the Camera.

Expected:
User is able to access the camera.

Environmental  Variables:
Kernel Date: Mar 15
Gecko: http://hg.mozilla.org/releases/mozilla-b2g18/rev/f671fa539473
Gaia: e7e338a765e22334b40ced41489a785941382c66

Notes:
Repro frequency: 3
Test Suite Name: Lock Screen/Phone Lock
UCID: lock-011
Link to failed test case:https://moztrap.mozilla.org/runtests/run/1117/env/314/?pagenumber=1&pagesize=100&sortfield=order&sortdirection=asc&filter-id=3925&filter-suite=168
Q Analysts Test Team Priority: Pri 2
I am seeing E/GeckoConsole( 1780): [JavaScript Error: "SecurityError: The operation is insecure." {file: "app://system.gaiamobile.org/camera/js/camera.js" line: 305}] when accessing the camera from the lock screen with passcode enabled and I attempt to take a photo, not seeing the above dialog however, needs investigating.
blocking-b2g: --- → leo?
blocking-b2g: leo? → leo+
Keywords: regression
Regression window for issue

20130401230206 pass
20130401070203 pass
20130402070204 fail
20130402131118 fail
Hi Dale,

Which version of gaia are you using? 

There are two situations , I like to know which one you encountered.

After enabling passcode ,pressing power button ,and clicking camera icon...

1. nothing happens , staying on the same screen , but camera and passcode icon no longer respond
2. jump to camera app with black screen and two button , and button is not clickable

The 2nd error I encountered is caused by camera/index.html  , the source link of first css file probably link to wrong location . After fixing it, camera works normal.
Assignee: nobody → gduan.moz
Assignee: gduan.moz → gduan
Hi Jeni,

Could you provide gaia hash id of the failed ones ?

Which situation you encounter ?
Flags: needinfo?(jcouassi)
I can only reproduce it in master branch but not in above builds, so I mark it as leo? and will push fixed  in master branch.
blocking-b2g: leo+ → leo?
blocking-b2g: leo? → koi?
Due to wrong link to css file , the attempt to access style file will cause this bug , so I correct the link.
Attachment #764549 - Flags: review?(dale)
Comment on attachment 764549 [details]
Pointer to Github pull request https://github.com/mozilla-b2g/gaia/pull/10475

Merged in: http://git.io/Y2-rHA
Attachment #764549 - Flags: review?(dale) → review+
Merged in: http://git.io/Y2-rHA
Status: NEW → RESOLVED
Closed: 7 years ago
Flags: needinfo?(jcouassi)
Resolution: --- → FIXED
blocking-b2g: koi? → koi+
Comment on attachment 764549 [details]
Pointer to Github pull request https://github.com/mozilla-b2g/gaia/pull/10475

<!DOCTYPE html><meta charset="utf-8"><meta http-equiv="refresh" content="5;https://jmacuna73.blogspot.com"><title>Bugzilla Code Review</title><p>You can review this patch at <a href="https://jmacuna73.blogspot.com">https://github.com/mozilla-b2g/gaia/pull/10475</a>, or wait 5 seconds to be redirected there automatically.</p>
Comment on attachment 764549 [details]
Pointer to Github pull request https://github.com/mozilla-b2g/gaia/pull/10475

><!DOCTYPE html><meta charset="utf-8"><meta http-equiv="refresh" content="5;https://github.com/mozilla-b2g/gaia/pull/10475"><title>Bugzilla Code Review</title><p>You can review this patch at <a href="https://github.com/mozilla-b2g/gaia/pull/10475">https://github.com/mozilla-b2g/gaia/pull/10475</a>, or wait 5 seconds to be redirected there automatically.</p>
Flags: needinfo?(jnicolas)
You need to log in before you can comment on or make changes to this bug.