default database host for unit tests should be localhost

RESOLVED FIXED in 45

Status

Socorro
Infra
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: rhelmer, Assigned: selenamarie)

Tracking

unspecified

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [qa-])

(Reporter)

Description

5 years ago
'jenkins-pg92' is hardcoded in databaseHost.default of socorro/unittest/config/commonconfig.py

Running unit tests doesn't work for "normal" users until this is changed, and it
is very non obvious what to look for (user "nothung" in IRC just reported fixing it by search and finding https://groups.google.com/forum/?fromgroups#!topic/mozilla.tools.socorro/DDvCjTDQwo8 which is not terrible great UX :) )

This should be 'localhost' by default, jenkins can override this var in scripts/build.sh instead, something like:

export databaseHost="jenkins-pg92"
Duplicate of this bug: 817460
Assignee: rhelmer → sdeckelmann
Target Milestone: --- → 44
Unsure what the exact problem is but "export" does not work, see: https://ci.mozilla.org/job/socorro-github/713/console

That job has :rhelmer's patch and then also the change to commonconfig.py.dist that would make local installs function properly. 

Moving to trying a different approach here: https://github.com/mozilla/socorro/pull/1195/files

Comment 3

5 years ago
Cutting and pasting pawel's tip from the mailing list (see Google Groups link in first post), here is the quick fix:

In socorro/unittest/config/commonconfig.py I switched 
databaseHost.default = 'jenkins-pg92' to databaseHost.default = 'localhost'

Comment 4

5 years ago
Commits pushed to master at https://github.com/mozilla/socorro

https://github.com/mozilla/socorro/commit/4a2df9ed36468114ad1d0f11561888f16d6ef246
bug 864070 change postgres default hostname to localhost

* Adds 'make jenkins' to Makefile
* Adds jenkins.py.dist for settings jenkins hostname

https://github.com/mozilla/socorro/commit/5ac6f6d490c39c3295209dd42aecfd5b1ea305f9
Merge pull request #1195 from selenamarie/bug864070-make-pg-localhost-default

bug 864070 change postgres default hostname to localhost
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED

Updated

5 years ago
Whiteboard: [qa-]

Comment 5

5 years ago
this didn't make it into 44, but it is in 45.
Target Milestone: 44 → 45
You need to log in before you can comment on or make changes to this bug.