Closed Bug 864150 Opened 7 years ago Closed 12 days ago

Make cookie viewer use the private database when in perma PB mode

Categories

(Firefox :: Private Browsing, defect)

x86_64
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: jdm, Unassigned)

References

Details

(Whiteboard: [tor 10353])

It would be good to solve the problem where people using "Never remember history" don't get to access their stored cookies. Since http://mxr.mozilla.org/mozilla-central/source/browser/components/preferences/cookies.js seems to use nsICookieManager, we could enhance that interface to give access to the private database. Ehsan, how do you feel about this?
I think that's a good idea, but isn't this a dupe of bug 777620?
Let's sort out the API changes there and make this about updating the cookie viewer.
Depends on: 777620
Duplicate of this bug: 1103690
Whiteboard: [tor 10353]

Cookie viewer is gone

Status: NEW → RESOLVED
Closed: 12 days ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.