Closed Bug 864152 Opened 7 years ago Closed 7 years ago

Intermittent browser_webconsole_network_panel.js | uncaught exception - TypeError: imageNode or elem is null at resource:///modules/devtools/webconsole/network-panel.js

Categories

(DevTools :: Console, defect)

x86
Windows 8
defect
Not set

Tracking

(firefox24 fixed, firefox25 fixed, firefox26 fixed)

RESOLVED FIXED
Firefox 26
Tracking Status
firefox24 --- fixed
firefox25 --- fixed
firefox26 --- fixed

People

(Reporter: philor, Assigned: msucan)

References

Details

(Keywords: intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=22068979&tree=Mozilla-Inbound
WINNT 6.2 mozilla-inbound debug test mochitest-browser-chrome on 2013-04-21 05:11:06 PDT for push 1547d8556df7
slave: t-w864-ix-035

06:13:46     INFO -  WARNING: ENSURE_TRUE(weakFrame.IsAlive()) failed: file e:/builds/moz2_slave/m-in-w32-d-0000000000000000000/build/layout/xul/base/src/nsXULPopupManager.cpp, line 935
06:13:46     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | test 9: sent form data
06:13:46     INFO -  ++DOCSHELL 2602FBF0 == 17 [id = 5290]
06:13:46     INFO -  ++DOMWINDOW == 119 (26030398) [serial = 13326] [outer = 00000000]
06:13:46     INFO -  ++DOMWINDOW == 120 (26030868) [serial = 13327] [outer = 26030398]
06:13:46  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | uncaught exception - TypeError: imageNode is null at resource://app/modules/NetworkPanel.jsm:540
06:13:46     INFO -  Stack trace:
06:13:46     INFO -      JS frame :: chrome://mochikit/content/tests/SimpleTest/SimpleTest.js :: simpletestOnerror :: line 1109
06:13:46     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
06:13:46     INFO -  JavaScript error: resource://app/modules/NetworkPanel.jsm, line 540: TypeError: imageNode is null
06:13:46     INFO -  TEST-INFO | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | Console message: [JavaScript Error: "TypeError: imageNode is null" {file: "resource://app/modules/NetworkPanel.jsm" line: 540}]
06:13:46     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | requestBody isVisible=false
06:13:46     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | requestFormData isVisible=true
06:13:46     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | requestCookie isVisible=true
06:13:46     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | responseContainer isVisible=true
06:13:46     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | responseBody isVisible=false
06:13:46     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | responseNoBody isVisible=false
06:13:46     INFO -  TEST-PASS | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | responseImage isVisible=false
06:13:46  WARNING -  TEST-UNEXPECTED-FAIL | chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js | responseImageCached isVisible=true - Got none, expected block
06:13:46     INFO -  Stack trace:
06:13:46     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: test_is :: line 502
06:13:46     INFO -      JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js :: checkIsVisible :: line 41
06:13:46     INFO -      JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js :: testGen :: line 395
06:13:46     INFO -      JS frame :: chrome://mochitests/content/browser/browser/devtools/webconsole/test/browser_webconsole_network_panel.js :: networkPanel._onUpdate/< :: line 381
06:13:46     INFO -      JS frame :: chrome://mochikit/content/browser-test.js :: test_executeSoon/<.run :: line 531
06:13:46     INFO -      native frame :: <unknown filename> :: <TOP_LEVEL> :: line 0
Summary: Intermittent browser_webconsole_network_panel.js | uncaught exception - TypeError: imageNode is null at resource://app/modules/NetworkPanel.jsm:540, | responseImageCached isVisible=true - Got none, expected block → Intermittent browser_webconsole_network_panel.js | uncaught exception - TypeError: imageNode or elem is null at resource:///modules/devtools/webconsole/network-panel.js
Duplicate of this bug: 901905
It seems the network panel code tries to update the iframe document before it is fully loaded. This patch attempts to fix the issue.

r=me (one-line change)

Landed: https://hg.mozilla.org/integration/fx-team/rev/2ea8259f7e39
Assignee: nobody → mihai.sucan
Status: NEW → ASSIGNED
Whiteboard: [fixed-in-fx-team]
https://hg.mozilla.org/mozilla-central/rev/2ea8259f7e39
Status: ASSIGNED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 26
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.