Last Comment Bug 864304 - Requesting needinfo from more than one person is annoying
: Requesting needinfo from more than one person is annoying
Status: RESOLVED FIXED
:
Product: bugzilla.mozilla.org
Classification: Other
Component: Extensions: Needinfo (show other bugs)
: Production
: x86 Mac OS X
: -- normal (vote)
: ---
Assigned To: David Lawrence [:dkl]
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-22 06:15 PDT by Boris Zbarsky [:bz] (still a bit busy)
Modified: 2013-04-23 08:50 PDT (History)
3 users (show)
See Also:
Due Date:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch to allow multiple needinfo to be entered in Other field (v1) (4.52 KB, patch)
2013-04-22 15:37 PDT, David Lawrence [:dkl]
glob: review-
Details | Diff | Splinter Review
Patch to allow multiple needinfo to be entered in Other field (v2) (4.55 KB, patch)
2013-04-23 08:25 PDT, David Lawrence [:dkl]
glob: review+
Details | Diff | Splinter Review

Description Boris Zbarsky [:bz] (still a bit busy) 2013-04-22 06:15:29 PDT
STEPS TO REPRODUCE:

1)  Load https://bugzilla.mozilla.org/show_bug.cgi?id=864228
2)  Scroll to the bottom.
3)  Check the "Need information from" box.
4)  Select "other" in the dropdown
5)  Type ":peterv, :bholley" in the textfield.
6)  Submit

ACTUAL RESULTS: "needinfo_from: :peterv, :bholley did not match anything"

EXPECTED RESULTS: Should work

ADDITIONAL INFORMATION: If I put that same string in the textfield I get by clicking "set flags" and setting "needinfo" to "?", then it works fine.  But that involves hunting down the "set flags" link.
Comment 1 David Lawrence [:dkl] 2013-04-22 15:18:21 PDT
I will see about making the Other text field allow for more than one address to be entered, similar to the Cc field.

dkl
Comment 2 David Lawrence [:dkl] 2013-04-22 15:37:47 PDT
Created attachment 740525 [details] [diff] [review]
Patch to allow multiple needinfo to be entered in Other field (v1)
Comment 3 Byron Jones ‹:glob› [PTO until 2017-01-09] 2013-04-23 00:29:18 PDT
Comment on attachment 740525 [details] [diff] [review]
Patch to allow multiple needinfo to be entered in Other field (v1)

Review of attachment 740525 [details] [diff] [review]:
-----------------------------------------------------------------

the layout of the 'other' box is broken due to the addition of the bz_userfield (which sets the width to 100%).  remove this class please.

if you enter a single name, you get:
Can't use string ("glob@mozilla.com") as an ARRAY ref while "strict refs" in use at ./extensions/Needinfo/Extension.pm line 111

::: extensions/Needinfo/Extension.pm
@@ +89,5 @@
>          foreach my $type (@{ $bug->flag_types }) {
>              next if $type->name ne 'needinfo';
> +            my %requestees;
> +
> +

nit: double blank line

@@ +126,1 @@
>                  }

nice!

@@ +126,4 @@
>                  }
>              }
> +
> +            next if !%requestees;

nit: you can remove this test, as the foreach loop will be a no-op if there aren't any requestees.
Comment 4 David Lawrence [:dkl] 2013-04-23 08:25:38 PDT
Created attachment 740841 [details] [diff] [review]
Patch to allow multiple needinfo to be entered in Other field (v2)
Comment 5 Byron Jones ‹:glob› [PTO until 2017-01-09] 2013-04-23 08:42:47 PDT
Comment on attachment 740841 [details] [diff] [review]
Patch to allow multiple needinfo to be entered in Other field (v2)

r=glob
Comment 6 David Lawrence [:dkl] 2013-04-23 08:50:19 PDT
Thanks

Committing to: bzr+ssh://dlawrence%40mozilla.com@bzr.mozilla.org/bmo/4.2             
modified extensions/Needinfo/Extension.pm
modified extensions/Needinfo/template/en/default/bug/needinfo.html.tmpl
Committed revision 8754.

Note You need to log in before you can comment on or make changes to this bug.