Work - Tabs appending under "Tabs from Other Devices" after Sync is completed multiple times

VERIFIED FIXED

Status

VERIFIED FIXED
5 years ago
4 years ago

People

(Reporter: kjozwiak, Assigned: ally)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: feature=work)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 740605 [details]
Example of tabs being appended

When syncing two different machines using the Sync feature, the same tabs will be appended under "Tabs from other devices" every time a "Sync" is completed.

Example:

- Two tabs are opened on Computer A (User Sync's)
- Sync with Computer B and the tabs appear under "Tabs from other devices" (the initial two from Computer A)
- Select Sync again on Computer B and you will notice that four tabs will appear under "Tabs from other devices" (the two initial and then the two duplicates)

Steps to reproduce the issue: (You will need two Windows 8 machines):

1) On Computer A, open Firefox Browser and select "Options" and then "Sync"
2) While still on Computer A, select "Set Up Firefox Sync" and then "Create a New Account" (Insert all the required information and create the account)
3) On the same machine (Computer A), open Firefox Metro and select "Sync" under the "Settings" charm and then select "Pair a device"
4) On Computer B, open Firefox Metro and then select "Sync" under the "Settings" charm and then select "Connect"
5) Insert the codes listed on Computer B into Computer A (Pair both of the machines)
6) Open two different tabs on Computer A and then select "Sync now" under "Settings" and then "Sync" (ensure that syncing is completed)
7) On Computer B, go into the "Settings" charm and then select "Sync" and then select "Sync now" (do this a few times)

- You will notice the two initial tabs will sync, but if you sync several more times, the same tabs will just keep getting appended under "Tabs from other Devices"
- I added a screenshot to illustrate the issue happening (reproduced it several times with different Firefox Syncing accounts)

Current Behavior:

- Same tabs keep getting appended until the "Tabs from other devices" gets completely full with the same tabs

Expected Behavior:

Shouldn't append the same tabs, if you have two tabs opened, it should only display two tabs even if you synced several times

*Note: This can happen automatically if you leave both of the browsers opened and they sync after a certain period of time*
(Assignee)

Comment 1

5 years ago
Kamil, it sounds like you are syncing between metrofx A, classic fx A("Firefox Browser" in step 1), and metrofx B. Is this correct? Can you reproduce this using only 2 firefoxen?
(Assignee)

Updated

5 years ago
Assignee: nobody → ally
(Assignee)

Comment 2

5 years ago
...I bet I didn't clear the grid before repopulating when I wrote the feature.
(Assignee)

Comment 3

5 years ago
Created attachment 742626 [details] [diff] [review]
clearing the grid

PopulateGrid() never clears the the results of last round's sync.

Picking on mbrubeck, since he reviewed the original patch (but feel free to reassign if you want to).
Attachment #742626 - Flags: feedback?(mbrubeck)
Comment on attachment 742626 [details] [diff] [review]
clearing the grid

Ship it. :)
Attachment #742626 - Flags: feedback?(mbrubeck) → review+

Updated

5 years ago
No longer blocks: 859003
Summary: Defect - Tabs appending under "Tabs from Other Devices" after Sync is completed multiple times → Work - Tabs appending under "Tabs from Other Devices" after Sync is completed multiple times
Whiteboard: feature=defect c=Sync_features u=metro_firefox_user p=0 → feature=work
(Assignee)

Comment 5

5 years ago
p = 2 I guess? Most of the work was tracking down the issue 

https://hg.mozilla.org/integration/mozilla-inbound/rev/20d62a6629f5
Thanks Ally.  Today I had to remove points from another Defect so we have capacity this iteration.  If Bug 864614 is ready to go then please do land it.  Let me know if you plan to and I'll add it to Iteration #6.
https://hg.mozilla.org/mozilla-central/rev/20d62a6629f5
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Comment 8

5 years ago
Went through the following "Defect" for Testing/Verification and found no issues. Used the following build:

http://ftp.mozilla.org/pub/mozilla.org/firefox/nightly/2013-05-09-03-10-47-mozilla-central/

Changed the following settings to make Firefox Metro "Sync" faster rather then waiting:

pref("services.sync.scheduler.singleDeviceInterval", 86400);
pref("services.sync.scheduler.idleInterval",         120);
pref("services.sync.scheduler.activeInterval",       120);
pref("services.sync.scheduler.immediateInterval",    90);
pref("services.sync.scheduler.idleTime",             120);

- Synced between two different Windows 8 machines for about 3 hours, Opening/Closing "Tabs" and making sure that the both machines displayed the correct # of websites without any grid issues
- Synced 14 different websites that spanned two columns and ensured that there wasn't any grid issues
Status: RESOLVED → VERIFIED
OS: Windows 8 Metro → Windows 8.1
You need to log in before you can comment on or make changes to this bug.