Site Identifier in Location Bar is broken

RESOLVED FIXED in Firefox 23

Status

()

defect
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: alice0775, Assigned: briansmith)

Tracking

({regression})

23 Branch
mozilla23
x86_64
All
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox23 fixed)

Details

Attachments

(3 attachments)

Build Identifier:
http://hg.mozilla.org/mozilla-central/rev/1150403342b2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:23.0) Gecko/20130422 Firefox/23.0 ID:20130422105838

Steps To Reproduce:
1. Open https://addons.mozilla.org/en-US/firefox/ (for example)

Actual Results:
Only Gray Pad Lock.

Expected Results:
Green Pad Lock and Organization Name

Regression window(m-i)
Good:
http://hg.mozilla.org/integration/mozilla-inbound/rev/c1483e6de03a
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130419 Firefox/23.0 ID:20130419153005
Bad:
http://hg.mozilla.org/integration/mozilla-inbound/rev/f9405d359a22
Mozilla/5.0 (X11; Linux i686; rv:23.0) Gecko/20130419 Firefox/23.0 ID:20130419153606
Pushlog:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=c1483e6de03a&tochange=f9405d359a22

Suspected : Bug 787155
Facepalm.
Assignee: nobody → bsmith
Posted image screen shot
Looks like we will succed with fixes and a test case (from bug 813418)

 https://tbpl.mozilla.org/?tree=Try&rev=025cf62c3b30
Posted patch fix v1Splinter Review
Attachment #741500 - Flags: review?
Attachment #741500 - Flags: review? → review?(bsmith)
keeping r+ from review in bug 813418.
Attachment #741501 - Flags: review+
Comment on attachment 741500 [details] [diff] [review]
fix v1

Review of attachment 741500 [details] [diff] [review]:
-----------------------------------------------------------------

Please verify that the b2g build actually picks up the option.

Thanks for taking this. Set the bug to assigned: cviecco.

::: configure.in
@@ +6446,5 @@
>  fi
>  AC_SUBST(MOZ_DISABLE_CRYPTOLEGACY)
>  
>  dnl ========================================================
> +dnl = Disable LIB_PKIX

s/LIB_PKIX/libpkix/
Attachment #741500 - Flags: review?(bsmith) → review+
https://hg.mozilla.org/mozilla-central/rev/0373ea7e7f54
https://hg.mozilla.org/mozilla-central/rev/45e73d8d89c9
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
You need to log in before you can comment on or make changes to this bug.