OdinMonkey: protect all the code pages on Windows

RESOLVED FIXED in Firefox 22

Status

()

Core
JavaScript Engine
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: luke, Assigned: luke)

Tracking

unspecified
mozilla23
Points:
---

Firefox Tracking Flags

(firefox22 fixed, firefox23 fixed)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 years ago
For some bizarre reason, TriggerOperationCallbackForAsmJSCode only protects the first page of executable code.  It should just pass module.functionBytes() like the non-Windows path.
(Assignee)

Comment 1

5 years ago
Created attachment 740912 [details] [diff] [review]
patch
Attachment #740912 - Flags: review?(sstangl)
Comment on attachment 740912 [details] [diff] [review]
patch

Review of attachment 740912 [details] [diff] [review]:
-----------------------------------------------------------------

Oh my.
Attachment #740912 - Flags: review?(sstangl) → review+
(Assignee)

Comment 4

5 years ago
Comment on attachment 740912 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 840282
User impact if declined: uninterruptible iloop in asm.js code
Testing completed (on m-c, etc.): m-c
Risk to taking this patch (and alternatives if risky): very low
Attachment #740912 - Flags: approval-mozilla-aurora?

Updated

5 years ago
Attachment #740912 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/mozilla-central/rev/649497c7a2e9
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
https://hg.mozilla.org/releases/mozilla-aurora/rev/dd9c8e4b7e0d
status-firefox22: --- → fixed
status-firefox23: --- → fixed
You need to log in before you can comment on or make changes to this bug.