Closed Bug 8649 Opened 23 years ago Closed 23 years ago

data: URLs (RFC2397) not working

Categories

(Core :: Networking, defect, P3)

defect

Tracking

()

VERIFIED FIXED

People

(Reporter: braden, Assigned: gordon)

References

()

Details

(Whiteboard: need mac prjs)

"data" URLs (per RFC2397) do not appear to be working. There should be two mandrill images displayed on this page. The first is from a PNG file accessed with a conventional URL. The second is an encoded PNG file placed inline in the HTML file in a "data" URL.
Assignee: don → pnunn
Component: Browser-General → ImageLib
QA Contact: leger → elig
elig...I think this is a dup of an issue you and pnunn already..yes?
This may be a subset of 2110, "URI scheme parsing, extensibility broken/missing".

Gagan? Pam? Braden?

Thanks!
Assignee: pnunn → gagan
Gagan:
I'm not getting a call to IL_GetImage().
It seems to stall out in NetlibMainLoop().
Reassigning to you, knowing that this will
probably be fixed in Necko landing.

-pn
While I don't know the exact scope of ImageLib, data URLs can be used for more
than just images. They should work anywhere that takes a URL--plug-in data,
linked resources (LINK, A), etc.

I do not think this is a dupe of 2110. That bug deals with the protocol
extensibility mechanism, and this deals with support for a specific protocol.
Past necko landing...
Target Milestone: M9 → M10
This should probably be done as a data: protocol handler which would internally
invoke the content convertor to appropriately give the correct image type
(binary) stream from the specified URL. Marking it for later. Cc'ing warren for
his comments.
Yes, you're right. A data: protocol handler is what we need.
I'm done with this protocol. I'm just waiting for a response from gagan
regarding some url parsing stuff and I'll check it in.
Assignee: gagan → valeski
Status: ASSIGNED → NEW
Jud asked for it... here you go! :)
Status: NEW → ASSIGNED
Whiteboard: windows works, waiting on Linux and mac build the new dir
I checked in my changes. Windows works now. Andreas is verifying a unix build,
then unix will be online. Mac still needs the prj.

Jud
Man, this is *sweet*.

I'm gonna go compile my whole Web site into one big file.

No, not really.
linux is up and running
Target Milestone: M10 → M13
Component: ImageLib → Necko
Hardware: PC → Macintosh
Summary: "data" URLs (RFC2397) not working → "data" URLs (RFC2397) not working on mac
Whiteboard: windows works, waiting on Linux and mac build the new dir → need mac prjs
Assignee: valeski → gordon
Status: ASSIGNED → NEW
Status: NEW → RESOLVED
Closed: 23 years ago
Resolution: --- → FIXED
Mac projects created and in the build.  I see the mandrills on the Mac.
Status: RESOLVED → VERIFIED
This appears to be fixed using the 1999092908 Mac OS build. Two mandrill images
appear. Eli feels nostalgic, remembering the image from a 1985 Amiga 1000 demo.
;)

braden@endofframe, would you like to please double-check this? (I'm not familiar
with RFC2397, and have only confirmed that your test case works.)

Thanks!
Bulk move of all Necko (to be deleted component) bugs to new Networking

component.
*** Bug 31486 has been marked as a duplicate of this bug. ***
I can't get this feature working on Linux 2000030709 build.  Is this broken or
am I just careless?
david.madore: I don't understand -- this is a mac bug, but you put a linux 
comment here. Also this bug is closed. Has this problem resurfaced?
Summary: "data" URLs (RFC2397) not working on mac → data: URLs (RFC2397) not working on mac
Mac/NT? Sorry, had to fix that. per #10, this bug is the allplats implementation
bug.
OS: Windows NT → All
Hardware: Macintosh → All
Summary: data: URLs (RFC2397) not working on mac → data: URLs (RFC2397) not working
I've created a similar bug for "long data in Data-URLs" #813139, that I think this should depend on. Thus this bug should be re-opened.
https://bugzilla.mozilla.org/show_bug.cgi?id=813139
It's completely unrelated. Blindly searching for "data URL" couldn't find a similar bug.
@Masatoshi: I don't follow your logic. How would a search for "data URL" prove that this is unrelated?  This bug states that RFC2397 is not working on mac. My bug report states that RFC2397 is not working on mac in certain cases... Seems similar to me.
You need to log in before you can comment on or make changes to this bug.