Farmlines in Games Pack rotates to portrait and screws up

VERIFIED DUPLICATE of bug 851642

Status

Tech Evangelism
Preinstalled B2G Apps
VERIFIED DUPLICATE of bug 851642
5 years ago
5 years ago

People

(Reporter: Simon Callan, Telefonica, Unassigned)

Tracking

Trunk
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [apps watch list])

(Reporter)

Description

5 years ago
Rotating Farm Lines in the Game pack from Landscape to portrait screws it up.

The home icon also doesn't do anything in landscape so you can't return to the main menu
(Reporter)

Comment 1

5 years ago
It's the same for all games in the Game pack.
(Reporter)

Comment 2

5 years ago
ZTE Open OPEN_FFOS_V1.0.0B01_TME

Updated

5 years ago
Whiteboard: [apps watch list1]
(Reporter)

Updated

5 years ago
Whiteboard: [apps watch list1] → [apps watch list1]

Updated

5 years ago
Group: partner-confidential
Component: Gaia → Preinstalled B2G Apps
Product: Boot2Gecko → Tech Evangelism
Version: unspecified → Trunk
Simon, does it work on app launch and stop working after some interaction? If yes, this sounds like bug 851642
(Reporter)

Comment 4

5 years ago
seems to work on startup, but if you go back to the home screen and reenter the app, it goes to Portrait
Alive thinks this is a problem the app developer needs to fix by listening for the visibilitychange event to handle the app switch to fix the orientation themselves. See https://bugzilla.mozilla.org/show_bug.cgi?id=851642#c14.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

5 years ago
Blocks: 871238

Updated

5 years ago
Flags: needinfo?(hkirschner)

Comment 6

5 years ago
Harald, please review and work with Tweensoft to resolve if it it on the developer to fix.  This is a TEF+ bug from Telefonica's perspective.
Should be fixed by bug 851642.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(hkirschner)
Resolution: --- → FIXED
Okay.
No longer blocks: 871238
Resolution: FIXED → DUPLICATE
Whiteboard: [apps watch list1] → [apps watch list]
Duplicate of bug: 851642
This confirmed fixed by bug 851642.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.