If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

URLs/paths passed along with the -private-window flag open in a non-private window

RESOLVED DUPLICATE of bug 864923

Status

()

Firefox
Private Browsing
RESOLVED DUPLICATE of bug 864923
5 years ago
5 years ago

People

(Reporter: Stephan Sokolow, Unassigned)

Tracking

22 Branch
x86_64
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:22.0) Gecko/20130418 Firefox/22.0
Build ID: 20130418112607

Steps to reproduce:

1. Make sure there's an existing non-private Firefox window open.
2. Run "firefox -private-window somefile.html"


Actual results:

A new private window opens at about:privatebrowsing and the provided file/URL is opened in a new tab in the non-private window.


Expected results:

The provided file/URL should have either opened in the new private window or not opened at all.

I prefer the former since scripting "chromium --incognito-mode <URL> ..." is the last reason I keep Chrome around aside from testing web pages.

Updated

5 years ago
Component: Untriaged → Private Browsing

Updated

5 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 864923
You need to log in before you can comment on or make changes to this bug.