Closed Bug 865112 Opened 7 years ago Closed 7 years ago

[A/V] frame stretch and blinking

Categories

(Firefox OS Graveyard :: Gaia::Video, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g18+ affected)

RESOLVED FIXED
blocking-b2g -
Tracking Status
b2g18 + affected

People

(Reporter: leo.bugzilla.gecko, Unassigned)

References

Details

Contact: hjlee7111@gmail.com

Build ID : 20130419115238

When I play 640x360 video clip, the bottom of video frame is stretched, sometimes.
(Other resolution looks like find but i'm sure because I have not checked various kind of resolution)
If you can touch the screen to show or remove progress bar, you can see it more frequently.

And more over, left side of frame is blinking.
It seems like the frame is shifted to right by 1~2 pixel.

This problem happens in the case of both local and streaming and both horizontal view and vertical view.
blocking-b2g: --- → leo?
I think this problem is mentioned here.

https://bugzilla.mozilla.org/show_bug.cgi?id=863441#c34
No minate to tef. I confirmed this bug on v1.0.1 buri device. It seems that stretch happens when the video is rendered by HwComposer. No stretch when the video is rendered by OpenGL.
blocking-b2g: leo? → tef?
MozBuild sitll can not enable HwComposer on buri. To use HwComposer on MozBuild, I needed to apply following patch. But still have a problem of web content rencering.

https://www.codeaurora.org/gitweb/quic/lf/?p=build.git;a=blob;f=patch/all/gecko/HWC-multirect-visible-region.patch;h=1e1f6bde3a648dceb9d3a7f8bff27054e2030936;hb=refs/heads/v1.1
I confirmed that this bug can be fix same way as in Bug 850566.
(In reply to Sotaro Ikeda [:sotaro] from comment #4)
> I confirmed that this bug can be fix same way as in Bug 850566.

Confirmed! Patch coming up
Actually it makes more sense to roll up this fix into the patch in bug 832383. I'll follow up there.
Depends on: 832383
(In reply to Diego Wilson [:diego] from comment #6)
> Actually it makes more sense to roll up this fix into the patch in bug
> 832383. I'll follow up there.

Thanks!
If this is going to be tackled in bug 832383 should we nominate that one instead?
Flags: needinfo?
Whiteboard: [tef-triage]
Yes, we should block on the fix in bug 832383 - leaving this one open though it could possibly be duped?
blocking-b2g: tef? → -
tracking-b2g18: --- → +
Flags: needinfo?
Whiteboard: [tef-triage]
I'd rather keep it open to make sure it's verified once the fix for bug 832383 lands
Blocks: 862952
No longer blocks: 862952
I cannot see this problem in the latest version.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.