Can't get the bookmark state of a current page without showing "bookmark menu" toolbar button

RESOLVED WONTFIX

Status

()

defect
RESOLVED WONTFIX
6 years ago
6 years ago

People

(Reporter: tetsuharu, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

[Environment]
http://hg.mozilla.org/mozilla-central/rev/fef5f202b2dc

After land bug 748894, "bookmark menu" toolbar icon shows the bookmark state of a current page. But the patch of bug 748894 does not include changesets for bookmark "sidebar" button.

If we use "bookmark sidebar" toolbar button instead of "bookmark menu" one, we cannot get the bookmark state of a current page.

Each bookmark toolbar buttons are an exclusive relation. User will not place both button to toolbar.
Blocks: 748894
Keywords: regression
And also, this problem is happen in the case which user don't show any bookmark button in toolbar but uses bookmark toolbar.

How do we resolve this problem?

My current opinion is that we cannot move the bookmark star button outside of the location bar. It's difficult now.
Summary: Can't get the bookmark state of a current page when showing only "bookmark sidebar" toolbar button → Can't get the bookmark state of a current page without showing "bookmark menu" toolbar button
The bookmarks sidebar button was not intended to change, and the bookmarks button is intended to replace the bookmarks menu, especially in Australis theme. While they look similar their intent is different.
This is not a regression, the sidebar button has never been intended to do anything more than opening the sidebar.
Removing the star button is intended by us for users not interested in bookmarks, it has nothing to do with the sidebar button, apart they both show a star.
I also think in future we may kill the sidebars in favor of an in-content ui.
Keywords: regression
I understand the plan of Australis theme about the sidebar button.

Though, when will we land in-content ui? If it's far, I seem we need to care about the sidebar button until then.
And how about the bookmarks toolbar?
Honestly, we didn't care about the sidebar button in many years, it's legacy technology likely to disappear. I think it's unlikely we may start now spending resources on it. Though, I'll surely track feedback across the various channels, as usual.

What's the point about the bookmarks toolbar?
(In reply to Marco Bonardo [:mak] from comment #4)
> What's the point about the bookmarks toolbar?

If user display the bookmarks toolbar only (without bookmarks menu or sidebar toolbar button), there is no information about the state of bookmark for a current page.
that setup doesn't make sense, you can drag the star button to the bookmarks toolbar.  Brefly removing something is not a good use-case to have an alternative to the removed item.
(In reply to Marco Bonardo [:mak] from comment #6)
> that setup doesn't make sense, you can drag the star button to the bookmarks
> toolbar.  Brefly removing something is not a good use-case to have an
> alternative to the removed item.

Oh. I forgot its feature which we can place toolbar buttons to bookmarks toolbar.
Marco, can we add a bookmark star to the sidebar button, which can toggle the sidebar with using the "menu" part of new "menu" button as toggle checkbox?
You can do whatever you want in an add-on, but I don't think we will overload the sidebar button with additional functionality.
By the way, in the case which user doesn't place any bookmarks toolbar button (he uses access his bookmarks via location bar), how does he get the bookmark state? This is rare case, isn't it?
if you remove the star by will, it's very unlikely you are interested in the bookmark state, indeed you likely removed it cause you don't care.

Comment 12

6 years ago
I access my bookmarks through the Mac menu bar, which has a nice big click target and allows a long menu to be shown.  I'd rather not have a toolbar button that does the same thing.
(In reply to Jesse Ruderman from comment #12)
> I access my bookmarks through the Mac menu bar, which has a nice big click
> target and allows a long menu to be shown.  I'd rather not have a toolbar
> button that does the same thing.

Except that only part of it does the same thing. It also exposes whether the current page is bookmarked or allows you to bookmark it with a single click, respectively.

This is the same inconsistent argument as in comment 5. You say you don't want the button because you consider it redundant, and then you complain that something is lost because the button wasn't actually redundant.

Comment 14

6 years ago
Before bug 748894, I could have the star without the redundant menu button.  Now, if I want the star, I'm forced to have a redundant menu button next to it.

What's inconsistent about that?
(In reply to Jesse Ruderman from comment #14)
> Before bug 748894, I could have the star without the redundant menu button. 
> Now, if I want the star, I'm forced to have a redundant menu button next to
> it.

The thing to account for is whether the price is worth it or not.
So, what's the price? By moving the star from the locationbar to the button, you may reduce the locationbar size and in the end the only thing you are losing is a few horizontal pixels (due to the dropmarker). This happens likely on a widescreen, where 90% of the times the locationbar is basically empty and taking up unused space.
Moreover the new button can be customized in any place of the ui, can be moved to the bookmarks toolbar (where it also takes far less space), on the tabbar, or on the add-ons bar. It can also be removed, provided one is not interested in bookmarks at all. This is additional customizability.
On the plus side, this change also solved many issues we had, from the bookmarks button magically moving around and fooling users, to special code to handle the star in an exotic place like the location bar (it's not really the right place to put buttons or widgets), to the problems with Ubuntu having a native menubar only in some cases and totally missing a bookmarks menu in such cases, or the fact Mac menubar popups don't live-update.
Plus the coherency win of having most bookmarks functionality collected in a single widget, with a few tweaks (some are expected for Australis) this may help the users figuring our where their bookmarks go and what the star means.
In addition to this, it's now very simple for an add-on to add a star-only or bookmarks-menu-only button, just by reusing the same code as this coalesced button, something not really easy to achieve before due to code complexity.

So, in the end I think the few lost horizontal pixels are a very low price for the gains I expressed above. I agree someone won't care about these wins, someone will consider some of them totally pointless. But as you well know it's hard to design anything for a so large audience, so it's not really about personal preference, more about cost/gain ratio.
I don't see anything actionable here. The new Star button seems to be working as intended, and the sidebar really isn't relevant as far as I can see.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INVALID

Comment 17

6 years ago
(Btw, bug 748894 was reverted in bug 867343, but only until Australis lands.)
Resolution: INVALID → WONTFIX

Comment 18

6 years ago
Filed bug 890789 for a clearer decision on Mac.  (I don't know what OS Tetsuharu uses.)
You need to log in before you can comment on or make changes to this bug.