Closed Bug 865270 Opened 7 years ago Closed 6 years ago

no way to cancel sending an email

Categories

(Firefox OS Graveyard :: Gaia::E-Mail, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 921050

People

(Reporter: dietrich, Unassigned)

References

Details

(Keywords: feature)

Unagi, v1-train, 4/24

STR:

1. from gallery share an image via email
2. enter TO: address and hit send
3. see the "sending email" screen with spinner

Expected: eventually sends and goes back to Email or Gallery (i don't know)

Actual: says "sending email" forever, and email never received
Blocks: 865274
bug 865274 is about the regression in step 3 of the STR.

this bug is just about having a cancel button there on that screen.
No longer blocks: 865274
Flags: needinfo?(kyee)
Duplicate of this bug: 860706
Seems to have been fixed in 865274.
Flags: needinfo?(kyee)
(In reply to Casey Yee [:cyee] from comment #3)
> Seems to have been fixed in 865274.

That bug was about sending failing, this bug is about there not being a way to cancel sending.  But send-in-background is on the short-list for v1.2 features, so this bug will probably be mooted in the 1.2 timeframe.
Did this happen in 1.2?
Keywords: feature
Send in background is now targeted at 1.4 on the even shorter short-list.
This is a somewhat common problem for me, e.g., if I'm walking away from the office and just about to get out-of-range of the wireless when I hit send.  (Though that has its own set of issues around why we don't determine that the network connection has failed, which I seem to think we do much faster if there isn't a network connection open!)
Send in background is being implemented on bug 921050 and is definitely landing for 2.0.  (It's in the feedback stage currently, should progress to review stage next week.)

I am duping this bug to 921050 since that use case supersedes this bug and I like duping bugs.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 921050
You need to log in before you can comment on or make changes to this bug.