Closed Bug 865273 Opened 7 years ago Closed 7 years ago

[sms] Utils.Template shouldn't throw an exception when ID isn't found.

Categories

(Firefox OS Graveyard :: Gaia::SMS, defect)

defect
Not set

Tracking

(b2g18 fixed)

RESOLVED FIXED
Tracking Status
b2g18 --- fixed

People

(Reporter: gnarf, Assigned: gnarf)

References

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_8_3) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.65 Safari/537.31

Steps to reproduce:

The Utils.Template function currently throws an exception when a node with a missing ID is not found.  It should just return an empty template.
Comment on attachment 741354 [details] [diff] [review]
GitHub pull request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): 
User impact if declined: 
Testing completed: 
Risk to taking this patch (and alternatives if risky):
String or UUID changes made by this patch:
Attachment #741354 - Flags: review?(felash)
Attachment #741354 - Flags: approval-gaia-v1?
Attachment #741354 - Flags: approval-gaia-v1?
Comment on attachment 741354 [details] [diff] [review]
GitHub pull request

r=me with the comments addressed
Attachment #741354 - Flags: review?(felash) → review+
Blocks: 845173
master: 3a01c77d24f435cf87423c484b9fba0bea276d75
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Comment on attachment 741354 [details] [diff] [review]
GitHub pull request

NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
Bug caused by (feature/regressing bug #): -
User impact if declined: -
Testing completed: yes
Risk to taking this patch (and alternatives if risky): very low, small patch and well unit tested part of the code
String or UUID changes made by this patch: -
Attachment #741354 - Flags: approval-gaia-v1?(21)
Comment on attachment 741354 [details] [diff] [review]
GitHub pull request

This seems super safe. I made a small comment about the code on github though.
Attachment #741354 - Flags: approval-gaia-v1?(21) → approval-gaia-v1+
Assignee: nobody → gnarf37
Uplifted 3a01c77d24f435cf87423c484b9fba0bea276d75 to:
v1-train: bf580053e5585a25ed252fcf4b0a4254dcb4e4ec
You need to log in before you can comment on or make changes to this bug.