Closed Bug 865394 Opened 7 years ago Closed 2 years ago

zimbra calendar events show multiple notifications

Categories

(Firefox OS Graveyard :: Gaia::Calendar, defect)

Other
Gonk (Firefox OS)
defect
Not set

Tracking

(Not tracked)

RESOLVED WONTFIX

People

(Reporter: dietrich, Unassigned)

References

Details

Attachments

(1 file)

screenshot: http://cl.ly/image/400k0E2R2E0n

unagi, 4/24 v1-train build
Something is definitely wrong here. Zimbra only supports single alarm account declarations, but we're firing multiple alarms here. 

==> leo?
blocking-b2g: --- → leo?
Wait a second, I can't reproduce. I just got an alarm notification from an event on zimbra and did not get this.

Can you attach a logcat?
blocking-b2g: leo? → ---
I am suspicions of these bugs.... My guess is some alarm record is not getting cleaned up when we edit it and our validation checks think its still fine to fire the alarm because the event's time has not changed.
Ugh, I can't really logcat this. I only see it after not looking at the phone for a while, but then noticing "wtf why do i have 22 notifications?!".

Often this means first thing in the morning.
Also have this on a Geeksphone Keon, 1.0.1.0 Build ID 20130705143611.  It happens consistently, but apparently different quantities of notifications, 3 4 or 5 notifications for a single event.
I get this too, pretty consistently, on an Inari. I usually get at least 6 notifications per event, sometimes in a cluster of 3 or 4, followed by another cluster of 3 or 4 a few seconds later.
OS: Mac OS X → Gonk (Firefox OS)
Hardware: x86 → Other
Can you take a look?
Flags: needinfo?(gaye)
Assignee: nobody → gaye
Flags: needinfo?(gaye)
Target Milestone: --- → 1.4 S1 (14feb)
Assignee: gaye → nobody
Target Milestone: 1.4 S1 (14feb) → ---
Is this an issue, I don't see it on neither of 1.3.0.0-prerelease (20140505203844) nor 2.0.0.0-prerelease (20140529160204)
Flags: needinfo?(dietrich)
Attached image 2014-06-11-15-06-20.png
master + m-c, nexus 4, built June 11.

two notifications for the same event, 3 minutes apart.
Flags: needinfo?(dietrich)
maybe this is related to the duplicate events? (Bug 1018833) - only happened for recurring events, if you had more than one account and only 5-6mo after the first sync.
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.