Last Comment Bug 865565 - D3E KeyboardEvent.key values of IME related keys should be considered with keyboard layout locale
: D3E KeyboardEvent.key values of IME related keys should be considered with ke...
Status: RESOLVED FIXED
: dev-doc-complete, inputmethod, intl
Product: Core
Classification: Components
Component: Widget: Win32 (show other bugs)
: Trunk
: x86_64 Windows 8
: -- normal (vote)
: mozilla25
Assigned To: Masayuki Nakano [:masayuki] (Mozilla Japan)
:
Mentors:
Depends on: 773526 842927
Blocks: 680830
  Show dependency treegraph
 
Reported: 2013-04-24 22:43 PDT by Masayuki Nakano [:masayuki] (Mozilla Japan)
Modified: 2013-07-22 03:44 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
Refer current keyboard layout locale at mapping from native keycode to D3E key name index on Windows (11.33 KB, patch)
2013-06-27 00:54 PDT, Masayuki Nakano [:masayuki] (Mozilla Japan)
jmathies: review+
bugs: review+
Details | Diff | Review

Description Masayuki Nakano [:masayuki] (Mozilla Japan) 2013-04-24 22:43:03 PDT
On Windows, some virtual keycode values for IME related keys are shared between Japanese keyboard layout and Korean keyboard layout. We should use different key values for them by checking the keyboard layout locale.

Additionally, some keys for IME cause OEM virtual keycodes. They should also be mapped with keyboard layout locale.
Comment 1 Masayuki Nakano [:masayuki] (Mozilla Japan) 2013-06-27 00:54:29 PDT
Created attachment 768199 [details] [diff] [review]
Refer current keyboard layout locale at mapping from native keycode to D3E key name index on Windows

See comment 0 for the detail.
Comment 2 Olli Pettay [:smaug] (high review load, please consider other reviewers) 2013-06-27 07:29:24 PDT
Comment on attachment 768199 [details] [diff] [review]
Refer current keyboard layout locale at mapping from native keycode to D3E key name index on Windows

I assume this makes us behave like IE does.
Comment 3 Masayuki Nakano [:masayuki] (Mozilla Japan) 2013-06-27 07:46:31 PDT
> I assume this makes us behave like IE does.

IE 10 doesn't support the special keys of Korean keyboard. They are mapped to "Unindentified".

Additionally, "FullWidth", "HalfWidth", "Alphanumeric", "Hiragana" and "Katakana" of Japanese keyboard layout are mapped to "Unidentified".

Finally, IE 10 maps "KanaMode" to "Attn" because the virtual keycode VK_ATTN is used for the Kana Mode/Roman Character mode key. I believe that this is a bug of IE because the key isn't actual "attention" key.

So, our implementation will advance one more step than IE 10.
Comment 4 Masayuki Nakano [:masayuki] (Mozilla Japan) 2013-06-27 17:58:54 PDT
https://hg.mozilla.org/integration/mozilla-inbound/rev/b5fddca814e0
Comment 5 Ed Morley [:emorley] 2013-06-28 06:39:47 PDT
https://hg.mozilla.org/mozilla-central/rev/b5fddca814e0
Comment 6 Masayuki Nakano [:masayuki] (Mozilla Japan) 2013-07-22 03:44:30 PDT
https://developer.mozilla.org/en-US/docs/Web/API/KeyboardEvent#Key_names_and_Char_values

Note You need to log in before you can comment on or make changes to this bug.