Separator key on NumPad of Brazilian keyboard should cause "Separator" key value

RESOLVED FIXED in mozilla23

Status

()

RESOLVED FIXED
6 years ago
5 years ago

People

(Reporter: masayuki, Assigned: masayuki)

Tracking

({intl})

Trunk
mozilla23
x86_64
Windows 8
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

According to <http://blogs.msdn.com/b/michkap/archive/2006/10/07/799605.aspx>, Separator key on Numpad of Brazilian keyboard causes VK_ABNT_C2 instead of VK_SEPARATOR. We should map it to "Separator" for KeyboardEvent.key.

I ordered Brazilian keyboard. I'll work on this after it comes.
Created attachment 743681 [details] [diff] [review]
Patch

Ugh, different Brazilian keyboard comes today :-(

Therefore, I couldn't test this patch with actual Brazilian ABNT keyboard.

However, fortunately, Japanese keyboard for Mac has "separator" key. And with it, I confirmed that Windows 8 uses VK_ABNT_C2 (0xC2) for it. And I can input "." by the key only when I select Portuguese of Brazil. So, I think that this patch works fine with actual Brazilian keyboard.
Attachment #743681 - Flags: review?(jmathies)

Updated

6 years ago
Attachment #743681 - Flags: review?(jmathies) → review+
https://hg.mozilla.org/mozilla-central/rev/70e8b142cbe0
Status: ASSIGNED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23

Comment 4

6 years ago
Just in case you did not see my comment on https://bugzilla.mozilla.org/show_bug.cgi?id=833719#c56 yet.  There are TWO “extra” keys on the Brazilian keyboard: C1 and C2.

AFAIU, C1 is much more important than C2.  Can you find a DOM code to map it to (since 0xC1 is, apparently, occupied)?
Depends on: 896362
You need to log in before you can comment on or make changes to this bug.