Closed Bug 865655 Opened 7 years ago Closed 7 years ago

SDK needs to be build using MOZ_FOLD_LIBS define

Categories

(Toolkit Graveyard :: XULRunner, defect)

22 Branch
x86_64
Windows 7
defect
Not set

Tracking

(firefox22 fixed, firefox23 fixed, firefox24 fixed)

RESOLVED FIXED
mozilla24
Tracking Status
firefox22 --- fixed
firefox23 --- fixed
firefox24 --- fixed

People

(Reporter: dganov, Assigned: glandium)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:22.0) Gecko/20130418 Firefox/22.0
Build ID: 20130418004017

Steps to reproduce:

I need XULRunner SDK to be compatible with appropriate Firefox version.


Actual results:

Due to nspr4.dll and others are missing I cannot work with Firefox 22 using SDK from XULRunner 22.


Expected results:

I believe XULRunner and Firefox must be both built using MOZ_FOLD_LIBS define
Component: Untriaged → XULRunner
Product: Firefox → Toolkit
Assignee: nobody → mh+mozilla
Attachment #748764 - Flags: review?(benjamin) → review+
https://hg.mozilla.org/mozilla-central/rev/09ebbdf6ff52
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla24
Comment on attachment 748764 [details] [diff] [review]
Enable MOZ_FOLD_LIBS in xulrunner for the SDK to match Firefox

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 648407
User impact if declined: SDK doesn't match Firefox, which prevents e.g. building binary components that can be properly loaded by Firefox.
Risk to taking this patch (and alternatives if risky): NPOTB for Firefox. Essentially, this takes a snippet from Firefox's confvars.sh and uses it when building xulrunner (which is what gets us the SDK)
String or IDL/UUID changes made by this patch: None
Attachment #748764 - Flags: approval-mozilla-beta?
Attachment #748764 - Flags: approval-mozilla-aurora?
Comment on attachment 748764 [details] [diff] [review]
Enable MOZ_FOLD_LIBS in xulrunner for the SDK to match Firefox

NPOTB
Attachment #748764 - Flags: approval-mozilla-beta?
Attachment #748764 - Flags: approval-mozilla-beta+
Attachment #748764 - Flags: approval-mozilla-aurora?
Attachment #748764 - Flags: approval-mozilla-aurora+
Product: Toolkit → Toolkit Graveyard
You need to log in before you can comment on or make changes to this bug.