Closed Bug 865746 Opened 7 years ago Closed 7 years ago

[HiDPI] Downloads panel icons are disproportionately large

Categories

(Firefox :: Downloads Panel, defect)

23 Branch
x86_64
Windows 7
defect
Not set

Tracking

()

RESOLVED FIXED
Firefox 23
Tracking Status
firefox22 + fixed
firefox23 --- fixed

People

(Reporter: edwardsgreg, Assigned: jfkthame)

References

(Blocks 1 open bug)

Details

Attachments

(3 files)

Just like Bug 818935, only with the new expanding downloads panel
Blocks: win-hidpi
This is the Windows version of the OS X patch in bug 815512 pt 2. On a hidpi configuration, the system may give us an icon that is larger (in pixel dimensions) than the CSS px size we want; we need to explicitly set the desired size in our CSS so that the extra pixels result in a sharp icon at the proper size, instead of a blurry icon at a larger CSS-px size.
Attachment #741947 - Flags: review?(mconley)
Assignee: nobody → jfkthame
Status: UNCONFIRMED → NEW
Ever confirmed: true
Hey Jonathan,

I know that bug 854555 took care of OSX, but are strangely sized icons in the Library also a problem for HiDPI displays in Windows?

If so, we should maybe update that here as well.

I don't have a HiDPI system to test with, so I can't say for certain if the Library will be a problem, but I suspect it might.

-Mike
Flags: needinfo?(jfkthame)
AFAICS, the Library looks OK on Windows/HiDPI - Greg, do you see a problem there, or only in the Downloads panel?
Flags: needinfo?(jfkthame) → needinfo?(edwardsgreg)
Actually, the reason downloads in the Library list are OK on Windows is that we already fixed that in bug 818935.
Flags: needinfo?(edwardsgreg)
Ah, gotcha, thanks.
Comment on attachment 741947 [details] [diff] [review]
[win-hidpi] explicitly set size of download item icons

Yep, this looks like the right move. Thanks!
Attachment #741947 - Flags: review?(mconley) → review+
https://hg.mozilla.org/mozilla-central/rev/da9f02088406
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: Firefox 24 → Firefox 23
Comment on attachment 741947 [details] [diff] [review]
[win-hidpi] explicitly set size of download item icons

[Approval Request Comment]
Bug caused by (feature/regressing bug #): windows hi-dpi support

User impact if declined: minor cosmetic glitch (icon too large)

Testing completed (on m-c, etc.): currently in Nightly and Aurora

Risk to taking this patch (and alternatives if risky): minimal, just a styling fix

String or IDL/UUID changes made by this patch: none
Attachment #741947 - Flags: approval-mozilla-beta?
Attachment #741947 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
mass remove verifyme requests greater than 4 months old
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.