Thunderbird csv export has wrong column label in french

RESOLVED FIXED

Status

Mozilla Localizations
fr / French
RESOLVED FIXED
5 years ago
5 months ago

People

(Reporter: bagu, Assigned: Bugzilla FR)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

667 bytes, text/plain
Details
(Reporter)

Description

5 years ago
Created attachment 741946 [details]
test.csv

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130409194949

Steps to reproduce:

Addressbook -> Tools -> Export -> chose csv


Actual results:

A file is correctly created, but, in french, column label have wrong values.

The country column have the state value and the state column have the country value.
And the professionnal and home column for address have the same label name.
Country and not Work_country for example.

See the attached file for complete example


Expected results:

The csv file should have the right label name.

Comment 1

5 years ago
Can you check if the naming is correct in the English version?

Comment 2

5 years ago
Checked with English version (17.0.5):
1. there are correct "Work Country" and "Home Country" labels.
2. state and country position is correct.
Which means there's no issue in English version.

Comment 3

5 years ago
OK, so it can be a translation problem. Moving to French component.
Assignee: nobody → bugzilla.fr
Component: Address Book → fr / French
Product: Thunderbird → Mozilla Localizations
QA Contact: benoit.leseul
Version: 17 → unspecified

Comment 4

5 years ago
As a hint here you are Outlook (csv) labels:
- work state: Dép/Région (bureau)
- work country: Pays/Région (bureau)
- home state: Dép/Région (domicile)
- home country: Pays/Région (domicile)

Comment 5

5 years ago
We have indeed a problem here:
http://transvision.mozfr.org/?sourcelocale=en-US&locale=fr&repo=central&search_type=strings&recherche=Home+Country

Is there a reference for Outlook labels somewhere? 

Also, I wonder if we should translate them at all since it blocks importing in other programs who only recognize English labels.

At least I had that problem with GMail/Google Apps. Their reference of recognized headers is quite incomplete: https://support.google.com/mail/answer/12119?hl=fr
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 6

5 years ago
Found complete list, however the list looks not in the same order as english version: http://cycocrew.pagesperso-orange.fr/delphi/WCManager.txt

Comment 7

5 years ago
Pushed the Outlook CSV values on central for Home/Work country:
http://hg.mozilla.org/l10n-central/fr/rev/947af0758133

This should fix the Country values, but we should probably review the whole field list by trying to import in various applications.
(In reply to Benoit from comment #7)
> Pushed the Outlook CSV values on central for Home/Work country:
> http://hg.mozilla.org/l10n-central/fr/rev/947af0758133
> 
> This should fix the Country values, but we should probably review the whole
> field list by trying to import in various applications.

Assuming this fixed the problem, if not please reopen.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.