Closed Bug 865827 Opened 7 years ago Closed 4 years ago

Pandora.com stops playing music after playing the first ad

Categories

(Core :: Audio/Video: Playback, defect, major)

x86
Windows 7
defect
Not set
major

Tracking

()

RESOLVED WORKSFORME
Tracking Status
firefox22 --- unaffected
firefox23 - affected

People

(Reporter: benjamin, Unassigned)

References

()

Details

(Keywords: regression, regressionwindow-wanted, testcase-wanted)

+++ This bug was initially created as a clone of Bug #841239 +++

This might be DOM stuff, dunno.

Pandora works for playing music (native <audio>). But after a while, it tries to play an ad. Near the end of the ad it just stops playing anything. The play/next buttons are disabled, so I cannot get back to normal music playing. I can switch channels, and other channels work until they try to play an audio ad.

Flash is enabled, click-to-play is off.

I have the console logging now, so I'll check for any interesting console spew the next time it happens to me. This has been happening for a while to me, but I didn't realize what was going on until recently, so I don't have a good regression range (and finding one is pretty hard, given that you have to wait for ads).
Summary: Pandora.com stops playing music due to jplayer error frequently, using nightly → Pandora.com stops playing music after playing the first ad
End of the console log:

[16:32:08.823] GET http://lt.andomedia.com/lt?guid=c3FsMDA1fjIzREYxNDY3LUFDOTgtNDFGNC1CRTA4LTg0QUI3NjJENUZEMX5lcDAwOQ%3D%3D&yob=1978&gender=M&zip=15905&hasads=1&devcat=WEB&devtype=WEB&cb=13669219280148349 [HTTP/1.1 200 OK 51ms]
--
[16:32:17.293] HTTP "Content-Type" of "text/html" is not supported. Load of media resource about:blank failed. @ https://www.pandora.com/
[16:32:17.357] GET http://www.pandora.com/radio/util/mediaserverPublicRedirect.jsp?file=/in-tuner/2013/03/Pandora_PandoraOne_Jira7024LNagelSpot1.mp3 [HTTP/1.1 302 Moved Temporarily 182ms]
[16:32:17.589] GET http://cont-sjl-1.pandora.com/public//in-tuner/2013/03/Pandora_PandoraOne_Jira7024LNagelSpot1.mp3 [HTTP/1.1 206 Partial Content]
[16:32:19.524] POST https://www.pandora.com/radio/xmlrpc/v35?rid=9942929P&lid=322883712&method=registerImpression&arg1=aHR0cDovL2FkLmRvdWJsZWNsaWNrLm5ldC9pbXA7djc7eDsyNjk0NTUyMjI7Mi0wOzE7MTUwMDkyMTc7MTM0LzE4NTs1MzI1Mjc2NS81MzE4MDE3NC8xOzt-YW9wdD0yLzAvZmYvMTt-b2t2PTtzZWdtZW50PTI7aW5kZXg9MjtmYW09LTE7Z2NhdD1ub25lO2dlbnJlPW5vbmU7YWc9MzU7Z25kPTE7emlwPTE1OTA1O2hvdXJzPTY7Y29tcGVkPTA7ZXhwPTA7ZmI9MDtkbWE9NTc0O2NsZWFuPTA7bXNhPTIxOTtzdD1QQTtjbz00MjExMTtldD0wO3Bpbj0wO2FhPTA7aGlzcD0wO2hoaT0wO2FuPTE7dT1sKmc0ejJzYWVpeXZmNWUhc2VnbWVudCoyIWluZGV4KjIhZmFtKi0xIWFnKjM1IWduZCoxIXppcCoxNTkwNSFkbWEqNTc0IWNsZWFuKjAhbXNhKjIxOSFzdCpQQSFjbyo0MjExMSFldCowIXBpbiowIWFhKjAhaGlzcCowIWhoaSowIWFuKjEhc3oqMTM0eDE4NSwyMDAweDEyIWdjYXQqbm9uZSFmYiowIWdlbnJlKm5vbmUhY29tcGVkKjAhZXhwKjAhaG91cnMqNjt0aWxlPTE7c3o9MTM0eDE4NSwyMDAweDEyO35jcz12JTNm&arg2=impression&arg3=a4fe1ef1-510f-4e86-88cd-2b6656ad475f [HTTP/1.1 200 OK 312ms]
[16:32:20.539] GET https://www.pandora.com/img/ads/generictile.png [HTTP/1.1 200 OK 550ms]
[16:32:20.540] GET https://www.pandora.com/radioAdEmbed.html?cb=13669219394611840 [HTTP/1.1 200 OK 89ms]
[16:32:20.648] The character encoding of a framed document was not declared. The document may appear different if viewed without the document framing it. @ https://www.pandora.com/radioAdEmbed.html?cb=13669219394611840
[16:32:20.729] POST https://www.pandora.com/radio/services/brokenAd.jsp [HTTP/1.1 200 OK 93ms]
--
[16:32:43.861] GET https://www.pandora.com/img/content-area/whyads-hover.png [HTTP/1.1 200 OK 277ms]
[16:32:44.343] GET https://www.pandora.com/img/content-area/drag_hover.png [HTTP/1.1 200 OK 272ms]
--
[16:33:08.836] GET http://lt150.tritondigital.com/lt?guid=VEQ0Mn5iNDBkMTUwMi05ZDdhLTRmZWQtYTZlOC1mNDAxNWFhNmQzNmM%3D&yob=1978&gender=M&zip=15905&hasads=1&devcat=WEB&devtype=WEB&cb=13669219880533741 [HTTP/1.1 200 OK 74ms]
[16:33:08.838] GET http://lt.andomedia.com/lt?guid=c3FsMDA1fjIzREYxNDY3LUFDOTgtNDFGNC1CRTA4LTg0QUI3NjJENUZEMX5lcDAwOQ%3D%3D&yob=1978&gender=M&zip=15905&hasads=1&devcat=WEB&devtype=WEB&cb=13669219880144006 [HTTP/1.1 200 OK 57ms]
--
[16:33:28.120] GET https://www.pandora.com/img/content-area/smallthumbs/background.png [HTTP/1.1 200 OK 349ms]
[16:33:28.121] GET https://www.pandora.com/img/content-area/smallthumbs/btn_down_sm.png [HTTP/1.1 200 OK 344ms]
[16:33:28.122] GET https://www.pandora.com/img/content-area/smallthumbs/menu_arrow.png [HTTP/1.1 200 OK 352ms]
[16:33:28.122] GET https://www.pandora.com/img/content-area/smallthumbs/btn_up_sm.png [HTTP/1.1 200 OK 355ms]

Note that I do get https mixed-content warnings for Pandora, which might be the cause of this. The only other thing that stands out is HTTP "Content-Type" of "text/html" is not supported. Load of media resource about:blank failed.

I will try with the mixed-content pref flipped.
Additional testing:
* The mixed-content pref does not seem to have any effect on this.
* The stopping happens at the *end* of the ad: that is, the audio ad plays to the end or at least very near the end. It's like the content JS isn't receiving a notification that it expects.

Next steps:
* I'm going to try this with Flash in disabled and click-to-play modes, to see whether that affects this. I also have a URL from cpearce which may make it easier to reproduce.
I can still reproduce this with Flash entirely disabled.
I happened to be listening to Pandora today on Aurora 23 and did not reproduce this can we get QA (or Bsmedberg) to repro with a current build?  If it can be reproduced still let's look for a regression range to help prod investigation.
Stephen, can you please see if you can reproduce this in the latest Aurora 23 build?
QA Contact: stephen.donner
I couldn't reproduce this today using:

* Build identifier: Mozilla/5.0 (Windows NT 6.1; rv:23.0) Gecko/20130522 Firefox/23.0
* Built from http://hg.mozilla.org/releases/mozilla-aurora/rev/10738444bf15
QA Contact: stephen.donner
Thanks Stephen, let's see if Benjamin can come back with the same results.
Keywords: qawanted
I can reproduce this (after a while) with 20130521
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #8)
> I can reproduce this (after a while) with 20130521

Benjamin, would you say this is less reproducible than before?
I don't have any way of estimating that.
Okay, thanks Benjamin.

How do you want to proceed Lukas?
(In reply to Anthony Hughes, Mozilla QA (:ashughes) from comment #11)
> Okay, thanks Benjamin.
> 
> How do you want to proceed Lukas?

Discussed in the channel meeting today. Benjamin can you please confirm with the latest Aurora build (Aurora 2013-06-04) does or does not reproduce this bug for you? QA testing and dogfooding has failed to reproduce this in the latest Aurora builds. Thanks.
Flags: needinfo?(benjamin)
On latest nightly, still reproduceable:

--
[09:19:23.854] "jPlayer error (count: 0): Media URL could not be loaded."
--
[09:16:41.740] "jPlayer error (count: 1): Media URL could not be loaded."
[09:16:43.456] "jPlayer error (count: 2): Media URL could not be loaded."
[09:16:45.844] "jPlayer error (count: 3): Media URL could not be loaded."
--
[09:20:58.303] HTTP "Content-Type" of "text/html" is not supported. Load of media resource about:blank failed. @ https://www.pandora.com/station/play/447444461949997184

I can reproduce this on latest-aurora also.

I got a link from Marc at Pandora which should make this more reproducable: http://www.pandora.com/?audioAd=264637989:51215314

This link runs an audio at after the first song, and with this link I can reliably reproduce the problem.

Note that you won't be able to reproduce this if you have a paid pandora-one account, because those don't run ads!
Flags: needinfo?(benjamin)
FYI, the normal audio stream for music tracks uses AAC+ (AAC-HE) encoded audio files, whereas the audio ads are typically in mp3 format.  We reuse <audio> nodes so perhaps it's an issue with switching from one codec to another on a single <audio> node?
Re-adding qawanted to try reproducing again with comment 13's instructions, and to try to find a regression window so that we can get an egr assignee.
Keywords: qawanted
(In reply to Marc Novakowski from comment #14)
> FYI, the normal audio stream for music tracks uses AAC+ (AAC-HE) encoded
> audio files, whereas the audio ads are typically in mp3 format.  We reuse
> <audio> nodes so perhaps it's an issue with switching from one codec to
> another on a single <audio> node?

Note that Windows 7 with no service pack installed can't play MP3 in <audio>, we were getting random crashes so we disabled MP3 on Win7 without service pack 1+ until such a time as our DirectShow support can land (bug 861693). Does Pandora fallback to Flash player for MP3 support in this case?
Yes, the code uses the jPlayer plugin which queries the browser using the audio.canPlayType() function to determine which codecs it supports natively.  For example:

document.createElement("audio").canPlayType('audio/mpeg; codecs="mp3"')

So assuming that Windows 7 no service pack returns "" (indicating no support), the plugin will use the Flash fallback.
(In reply to Marc Novakowski from comment #17)
> Yes, the code uses the jPlayer plugin which queries the browser using the
> audio.canPlayType() function to determine which codecs it supports natively.
> For example:
> 
> document.createElement("audio").canPlayType('audio/mpeg; codecs="mp3"')
> 
> So assuming that Windows 7 no service pack returns "" (indicating no
> support), the plugin will use the Flash fallback.

Great! Yes, we return "" for canPlayType('audio/mpeg; codecs="mp3"') on Windows 7SP0. I was just checking to eliminate that possibility.
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #13)
> [09:20:58.303] HTTP "Content-Type" of "text/html" is not supported. Load of
> media resource about:blank failed. @
> https://www.pandora.com/station/play/447444461949997184
> 
> I got a link from Marc at Pandora which should make this more reproducable:
> http://www.pandora.com/?audioAd=264637989:51215314

I tried loading both of these URLs and they do nothing, just redirect me back to www.pandora.com. Can you please create a minimized testcase which reproduces this more reliably?
Flags: needinfo?(benjamin)
Keywords: testcase-wanted
They do redirect to pandora.com, then play one song and an audio ad.
Flags: needinfo?(benjamin)
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #20)
> They do redirect to pandora.com, then play one song and an audio ad.

I'm not getting any music on my end. Do I need to search for a song and let it play until an ad comes through?
Still not reproducing, I'm going to need someone to provide more detailed steps to reproduce or to find the regression window themselves using the mozregression tool [1].

Here are the steps I'm following:
1. Navigate to http://www.pandora.com/?audioAd=264637989:51215314
2. Search for an artist and select it to start playing their station
3. Let a song play through to an ad
> Ad starts playing
4. Let the ad play through to the next song
> Next song starts playing

[1] http://mozilla.github.io/mozregression/
You're using win7, right? This won't reproduce on winxp which still uses Flash.

Given that we can reproduce, it may be more worthwhile to generate a minimized testcase. Anyone up for trying that?
Flags: needinfo?
(In reply to Benjamin Smedberg  [:bsmedberg] from comment #23)
> You're using win7, right? This won't reproduce on winxp which still uses
> Flash.

Yes, all my testing thus far has been on Windows 7. QA has as of yet been unable to reproduce this in a current Firefox build. We'll need someone who's able to reproduce this to come up with a reliable minimized testcase before we can be of any more assistance.
Flags: needinfo?
Keywords: qawanted
I've sent out a request to Mozillians asking for help reproducing this with the current build, hopefully we'll find a hardware combo (or more) - will report back if anyone gets in touch.
FYI, looks like Pandora is now only available in the US, Australia, and New Zealand. The text below is shown when I try to access the site in Canada.


Dear Pandora Visitor,

We are deeply, deeply sorry to say that due to licensing constraints, we can no longer allow access to Pandora for listeners located outside of the U.S., Australia and New Zealand. We will continue to work diligently to realize the vision of a truly global Pandora, but for the time being we are required to restrict its use. We are very sad to have to do this, but there is no other alternative.

We believe that you are in Canada (your IP address appears to be X.X.X.X). If you believe we have made a mistake, we apologize and ask that you please email us.

If you have been using Pandora, we will keep a record of your existing stations and bookmarked artists and songs, so that when we are able to launch in your country, they will be waiting for you.

We will be notifying listeners as licensing agreements are established in individual countries. If you would like to be notified by email when Pandora is available in your country, please enter your email address below. The pace of global licensing is hard to predict, but we have the ultimate goal of being able to offer our service everywhere.

We share your disappointment and greatly appreciate your understanding.

Sincerely,

Tim Westergen

Tim Westergren
Founder
If you have a people.mozilla.com account, or ssh access to another server in the USA, you can ssh tunnel through that to make it appear that you're in the USA.
Chris, right. VPN works as well as long as you set the "redirect-gateway" directive in the config file to force all traffic through Mozilla's network.
I tried it on MacOSX 10.8.3 and the 23.0 release, and Pandora continued playing after the first ad.
To reproduce this issue you need to:

* Be running Firefox on Windows,
* be a logged in registered Pandora user,
* not be a Pandora a paid user,
* be using Pandora's HTML5 player by loading Pandora from this URL: http://www.pandora.com/?disableForceFlash=true
I cannot reproduce this bug.

I'm on Windows 7 using Firefox beta v.23.0. I registered for Pandora and I'm not a paid member. I went to this URL: http://www.pandora.com/?disableForceFlash=true and played some music for a while. I ran it long enough for two audio ads to play, and after each ad it kept playing music with no problems.

My Firefox has no Flash installed at all, so the regular pandora.com with Flash will not work at all with it.
Windows 7, Firefox 23.0, registered and logged in but not a paid member, using the non-flash interface (w/ Flash disabled in the browser).

I cannot repro this bug either; however, this is only because I didn't hear any advertisements (!).  I let the player for for over two hours and it just streamed music without interruptions.  How long does one normally have to wait for an advertisement to play ?
OS X 10.8.4, Firefox 23.0 using non-flash
Played one song, got an add and then the next song played, no repro
Considering the steps in comment 30 and the lack of reproducible-ness for creating a test case, I'm thinking this is no longer a release blocker.
As I told you in email, pandora turned off HTML5 <audio> for this bug and another one, so I'm not sure why you were considering it a release blocker to begin with.
Component: Audio/Video → Audio/Video: Playback
See Also: → 1164080
I listed to Pandora on a Win10 trunk build for many hours today (using http://www.pandora.com/?disableForceFlash=true and denying the Flash click-to-play prompt to ensure HTML audio). I heard many ads during that time. Playback never stopped.

Can anybody still reproduce the issue this bug was filed for? I'm also wondering how useful a regressionwindow is going to be in this bug at this point anyway given how much our media playback pipeline has changed since mid-2013.
Between comment 36 and bug 1164080, I'm going to close this out as worksforme. Feel free to reopen if you're still able to reproduce.
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.