DeprecationWarning manage.py cron unconfirmed

RESOLVED FIXED in 2013-05-09

Status

Marketplace
API
P2
normal
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: clouserw, Assigned: ashort)

Tracking

2013-05-09
Points:
---

Details

(Reporter)

Description

5 years ago
This happened in dev, stage, and prod:

django.db.utils.DatabaseError: (1146, "Table 'addons_mozilla_org.api_auth_tokens' doesn't exist")
This is because migration 539 drops that table, while the cron still references it:

https://github.com/mozilla/zamboni/blob/master/apps/amo/cron.py#L206

I don't know enough about the reasons for dropping this table to touch anything, so I'm copying Mr. Short, who added the migration.

Comment 2

5 years ago
Its also here: https://github.com/mozilla/zamboni/blob/master/configs/mysql-anonymous/anonymize.yml#L16
(Reporter)

Updated

5 years ago
Assignee: nobody → ashort
Priority: -- → P2
(Assignee)

Comment 3

5 years ago
https://github.com/mozilla/zamboni/commit/7f4304d78b53
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
(Reporter)

Updated

5 years ago
Target Milestone: --- → 2013-05-09
You need to log in before you can comment on or make changes to this bug.