All users were logged out of Bugzilla on October 13th, 2018

[Buri][RESET] after send USSD

RESOLVED FIXED

Status

P1
normal
RESOLVED FIXED
6 years ago
6 years ago

People

(Reporter: sync-1, Assigned: cyang)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments)

(Reporter)

Description

6 years ago
Created an attachment (id=399219)
 Video
 
 AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.080
 Firefox os  v1.0.1
 Mozilla build ID:20130418070206
 
 +++ This bug was initially created as a clone of Bug #446323 +++
 
 DEFECT DESCRIPTION: Device is reproducing reset 100% after send USSD command *#124#. as you can see in attach video device will go to welcome screen after send the reject of network.
 
 I try to send logs for you tomorrow.
 
  EXPECTED BEHAVIOUR: Avoid reset.
 
  REPRODUCING PROCEDURES:
 1.- Send USSD with *#124# command.
 2.- network will answer with "unknown application" then the device reset.
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT: Blocking homologation issue
 
  REPRODUCING RATE:100%
 
  For FT PR, Please list reference mobile's behavior:
 
 ++++++++++ end of initial bug #446323 description ++++++++++
 
 
 
 CONTACT INFO (Name,Phone number):
 
  DEFECT DESCRIPTION:
 
  REPRODUCING PROCEDURES:
 
  EXPECTED BEHAVIOUR:
 
  ASSOCIATE SPECIFICATION:
 
  TEST PLAN REFERENCE:
 
  TOOLS AND PLATFORMS USED:
 
  USER IMPACT:
 
  REPRODUCING RATE:
 
  For FT PR, Please list reference mobile's behavior:
(Reporter)

Comment 1

6 years ago
Clone from brother
(Reporter)

Comment 2

6 years ago
Created attachment 742263 [details]
Video_USSD_sending_reset

Clone from brother

Updated

6 years ago
blocking-b2g: --- → tef?
what's the purpose of this code and expected behaviror? *#124#
Flags: needinfo?(sync-1)
Flags: needinfo?(sync-1) → needinfo?(chengan.xiong)

Comment 4

6 years ago
Created attachment 744380 [details]
log based on version of Mozilla build ID: 20130422230201
Flags: needinfo?(chengan.xiong)

Comment 5

6 years ago
Command *#125# and *#126# are some USSD used by TELEFONICA for NIPPER service,
this is use to pay in some places with the credit on device, is like a money
transfer, it is not to much used in Mexico, the problem is than device after
receive de USSD responds from network device reproduce reset 100%.
Attach some logs from tahiti as good reference.
(In reply to Cheng-An, XIONG from comment #4)
> Created attachment 744380 [details]
> log based on version of Mozilla build ID: 20130422230201

There are no REQUEST_SEND_USSD requests in the attached logs. Could you provide/attach the |adb logcat -b radio| output after reproducing the issue please? Thanks.
(In reply to José Antonio Olivera Ortega [:jaoo] PTO until 3rd May from comment #6)
> There are no REQUEST_SEND_USSD requests in the attached logs. Could you
> provide/attach the |adb logcat -b radio| output after reproducing the issue
> please? Thanks.

This is what we get after performing a test:

D/RIL_QC_B2G(  145): [0130]> CANCEL_USSD
D/RIL_QC_B2G(  145): [0130]< CANCEL_USSD
D/RIL_QC_B2G(  145): [UNSL]< UNSOL_SIGNAL_STRENGTH {[signalStrength=30,bitErrorRate=255,CDMA_SS.dbm=-1,CDMA_SSecio=-1,EVDO_SS.dbm=-1,EVDO_SS.ecio=-1,EVDO_SS.signalNoiseRatio=-1,LTE_SS.signalStrength=99,LTE_SS.rsrp=-32767,LTE_SS.rsrq=-32767,LTE_SS.rssnr=-32767,LTE_SS.cqi=-32767}
D/RIL_QC_B2G(  145): [0131]> SEND_USSD (*#124#)
D/RIL_QC_B2G(  145): [0131]< SEND_USSD
D/RIL_QC_B2G(  145): [UNSL]< UNSOL_ON_USSD {0,Servicio no disponible}
D/RIL_QC_B2G(  145): [0132]> CANCEL_USSD
D/RIL_QC_B2G(  145): [0132]< CANCEL_USSD

Updated

6 years ago
Assignee: nobody → cyang
(Assignee)

Comment 8

6 years ago
From the video, it does not appear that USSD is causing the problem as the phone crashed a few seconds after USSD was displayed. Since I cannot reproduce this here, please attempt to run with gdb attached to verify if the crash is caused by USSD. If it is a USSD caused crash, please upload the stack trace via our SR system and we can provide support there.
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → INCOMPLETE

Updated

6 years ago
blocking-b2g: tef? → ---

Comment 9

6 years ago
Created attachment 746178 [details]
Log

Comment 10

6 years ago
New log added.
blocking-b2g: --- → tef?

Comment 11

6 years ago
Problem still been reproduced in SW 126, 

Command *#125# and *#126# are some USSD used by TELEFONICA for NIPPER service,
this is use to pay in some places with the credit on device, is like a money
transfer, it is not to much used in Mexico, the problem is than device after
receive de USSD responds from network device reproduce reset 100%.
Attach some logs from tahiti as good reference.
We understand that's this is still an issue, so please create an SR for this so that we can support you immediately.   Please also provide the SR # here so that I can confirm it is routed appropriately.  Thanks!

Comment 13

6 years ago
I will do it.

Updated

6 years ago
Duplicate of this bug: 865950

Comment 15

6 years ago
Hi Carol, I've logged a case at Qualcomm. The case number is 01182745. And I add back trace when crashing.
Flags: needinfo?(cyang)
partner tracking in SR. clear blocking flag
blocking-b2g: tef? → ---
(Assignee)

Comment 17

6 years ago
Thanks weijia! This has been fixed and will be included in AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.103
Flags: needinfo?(cyang)
Resolution: INCOMPLETE → FIXED
(Reporter)

Comment 18

6 years ago
available in AU_LINUX_GECKO_ICS_STRAWBERRY_V1.01.00.01.019.103
You need to log in before you can comment on or make changes to this bug.