Closed Bug 866259 Opened 8 years ago Closed 8 years ago

vector images need the unlocked draw notification too

Categories

(Core :: ImageLib, defect)

x86_64
Linux
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla23
Tracking Status
firefox21 --- unaffected
firefox22 + fixed
firefox23 + fixed

People

(Reporter: tnikkel, Assigned: tnikkel)

References

Details

(Keywords: regression, Whiteboard: [qa?])

Attachments

(1 file)

Attached patch patchSplinter Review
Currently we use nsIDocument::Add/RemoveImage to track/untrack images that are visible or close to visible. But Add/RemoveImage also calls Increment/DecrementAnimationConsumers on the image (in addition to Lock/Unlock). This means our tracking is also responsible for handling images that should be animated (but don't care about locks). So we need to call our unlocked draw notification for vector images too, so they can animate.

This may change when we start tracking both when an image is in an active tab and when it is visible its current tab
Attachment #742530 - Flags: review?(joe)
Attachment #742530 - Flags: review?(joe) → review+
Comment on attachment 742530 [details] [diff] [review]
patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 689623
User impact if declined: dynamically added img's that contain svg won't animate
Testing completed (on m-c, etc.): just landed on inbound now
Risk to taking this patch (and alternatives if risky): this is a relatively safe patch, I think the risk of not taking it is higher than the risk of taking it
String or IDL/UUID changes made by this patch: none
Attachment #742530 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/be2a35cd5739
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Attachment #742530 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Is there any testing is needed?
If you wanted to verify that this is fixed you could dynamically add an img element that contains an svg file with animation (contains an animated gif or has svg animation, etc).
Whiteboard: [qa?]
You need to log in before you can comment on or make changes to this bug.