Intermittent test_osfile_async.xul | system_shutdown: Log message observervation promise was rejected as expected | system_shutdown: Log messages observervation promise was rejected

RESOLVED FIXED in Firefox 26

Status

()

Toolkit
OS.File
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: RyanVM, Assigned: yzen)

Tracking

({intermittent-failure})

Trunk
mozilla26
x86
Windows XP
intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(firefox25 wontfix, firefox26 fixed, firefox-esr24 wontfix)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

5 years ago
Regression from bug 862570.

https://tbpl.mozilla.org/php/getParsedLog.php?id=22295695&tree=Mozilla-Inbound

Rev3 WINNT 5.1 mozilla-inbound debug test mochitest-other on 2013-04-26 12:42:58 PDT for push 089bfd3486f5
slave: talos-r3-xp-060

13:01:00     INFO -  15338 INFO TEST-INFO | chrome://mochitests/content/chrome/toolkit/components/osfile/tests/mochi/test_osfile_async.xul | system_shutdown: waitObservation timeout exceeded.
13:01:00     INFO -  15339 INFO TEST-INFO | chrome://mochitests/content/chrome/toolkit/components/osfile/tests/mochi/test_osfile_async.xul | system_shutdown: waitObservation timeout exceeded.
13:01:00     INFO -  OS Agent Received message {"fun":"SET_DEBUG","args":[false],"id":243}
13:01:00     INFO -  OS Agent Calling method SET_DEBUG
13:01:00     INFO -  15340 INFO TEST-INFO | chrome://mochitests/content/chrome/toolkit/components/osfile/tests/mochi/test_osfile_async.xul | system_shutdown: Unregistered listener for resource chrome\toolkit\components\osfile\tests\mochi\main_test_osfile_async.js
13:01:00     INFO -  15341 ERROR TEST-UNEXPECTED-FAIL | chrome://mochitests/content/chrome/toolkit/components/osfile/tests/mochi/test_osfile_async.xul | system_shutdown: Log message observervation promise was rejected as expected.
13:01:00     INFO -  OS Agent Method SET_DEBUG succeeded
13:01:00     INFO -  OS Agent Sending positive reply undefined id is 246
Comment hidden (Treeherder Robot)
(Reporter)

Comment 2

5 years ago
BTW, nice typo in that error message. Might want to fix that up while you're fixing this failures :)
Summary: Intermittent test_osfile_async.xul | system_shutdown: Log message observervation promise was rejected as expected. → Intermittent test_osfile_async.xul | system_shutdown: Log message observervation promise was rejected as expected | system_shutdown: Log messages observervation promise was rejected
(Assignee)

Updated

5 years ago
Assignee: nobody → yura.zenevich
(Assignee)

Comment 3

5 years ago
It looks like the timeout might be a little too small. I could not reproduce this issue on my machine. Do you think we should increase it slightly? Perhaps half a second, if that's not too much? Thanks.
Flags: needinfo?(dteller)
It's worth trying. So far, the two failures are under Windows, so you might wish to:
- increase timeout;
- measure and log how much time it actually takes to receive the message, for future reference;
- try this through the Windows TryServer.
Flags: needinfo?(dteller)
(Assignee)

Comment 5

5 years ago
Created attachment 743156 [details] [diff] [review]
Patch for 866293.

https://tbpl.mozilla.org/?tree=Try&rev=9f35d83cb1bf
Attachment #743156 - Flags: review?(dteller)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 7

5 years ago
The try does not seem to have the issue. Let me know if there's anything else I should add/change?
Flags: needinfo?(dteller)
Comment hidden (Treeherder Robot)
Comment on attachment 743156 [details] [diff] [review]
Patch for 866293.

Review of attachment 743156 [details] [diff] [review]:
-----------------------------------------------------------------

Looks good to me. If the issue arises again, we should have some information from the additional logs (using Try Runs that succeed, that is) that would help us adjust the timeout.

An alternative would be to push the timeout to something extreme, say, 20 seconds, but that would probably be overkill.
Attachment #743156 - Flags: review?(dteller) → review+
Flags: needinfo?(dteller)
(Assignee)

Updated

5 years ago
Keywords: checkin-needed
(Reporter)

Comment 10

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/d2348909462c
Keywords: checkin-needed
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 13

5 years ago
https://hg.mozilla.org/mozilla-central/rev/d2348909462c
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla23
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Reporter)

Comment 17

5 years ago
Not as frequent as it used to be, but still happening...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Comment hidden (Treeherder Robot)
(Assignee)

Comment 19

5 years ago
Created attachment 754542 [details] [diff] [review]
Tests for 866293 (timeout).

https://tbpl.mozilla.org/?tree=Try&rev=69b7542be19d
Attachment #754542 - Flags: review?(dteller)
Attachment #754542 - Flags: review?(dteller) → review+
(Assignee)

Updated

5 years ago
Attachment #743156 - Attachment is obsolete: true
(Assignee)

Updated

5 years ago
Keywords: intermittent-failure → checkin-needed
(Reporter)

Updated

5 years ago
Keywords: intermittent-failure
(Assignee)

Comment 20

5 years ago
Apologies for removing the flag by accident.
(Reporter)

Comment 21

5 years ago
https://hg.mozilla.org/integration/mozilla-inbound/rev/ffea3a88169e
Keywords: checkin-needed
(Reporter)

Comment 22

5 years ago
https://hg.mozilla.org/mozilla-central/rev/ffea3a88169e
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → FIXED
Target Milestone: mozilla23 → mozilla24
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
yzen, could you take a look at this?
Flags: needinfo?(yura.zenevich)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
(Assignee)

Comment 39

4 years ago
As per Yoric's message: http://krijnhoetmer.nl/irc-logs/developers/20130910#l-3281
Flags: needinfo?(yura.zenevich)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Depends on: 913899
This should have be fixed by bug 913899.
Please reopen if necessary.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → FIXED
(Reporter)

Comment 44

4 years ago
Possible to uplift to 25?
status-firefox25: --- → affected
status-firefox26: --- → fixed
status-firefox-esr24: --- → affected
Target Milestone: mozilla24 → mozilla26
The patch that fixes the issue as a side-effect is quite experimental and changes part of the shutdown of Firefox. I would rather avoid uplifting it at least until we are reasonably certain that we have not increased the number of shutdown freezes.
(Reporter)

Comment 46

4 years ago
OK, seems very unlikely that it'll get beta approval then. If I hit this on beta/esr24, I will just disable the test.
status-firefox25: affected → wontfix
status-firefox-esr24: affected → wontfix
Anyway, the test only ensures that some warning is displayed as expected. This is useful only for Firefox developers and add-on developers.
You need to log in before you can comment on or make changes to this bug.