Drawing WebGL content to Canvas 2d and vice versa is very slow

RESOLVED DUPLICATE of bug 729385

Status

()

RESOLVED DUPLICATE of bug 729385
6 years ago
5 years ago

People

(Reporter: cabanier, Unassigned)

Tracking

(Depends on: 1 bug)

Trunk
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

6 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.31 (KHTML, like Gecko) Chrome/26.0.1410.64 Safari/537.31

Steps to reproduce:

Copying data from/to 2d context to/from a webgl context.
Example here: http://jsfiddle.net/zsmyK/9/


Actual results:

Very slow performance on Firefox. Much worse than one chrome in certain cases (Chrome seems to 'remember' that a texture was already uploaded in the test case)


Expected results:

Since both canvas and webgl are on the gpu, copying data should be very fast.
(Reporter)

Updated

6 years ago
Component: Untriaged → General
(Reporter)

Updated

6 years ago
See Also: → bug 729385
(Reporter)

Updated

6 years ago
Depends on: 729385
Component: General → Canvas: 2D
Product: Firefox → Core
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 729385
You need to log in before you can comment on or make changes to this bug.