Closed Bug 866407 Opened 7 years ago Closed 7 years ago

Ctrl-N in private mode creates a new non-private window and restores session(if that's the configuration)

Categories

(Firefox :: Private Browsing, defect)

20 Branch
x86_64
Linux
defect
Not set

Tracking

()

RESOLVED INVALID

People

(Reporter: diaasami, Unassigned)

Details

User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:20.0) Gecko/20100101 Firefox/20.0
Build ID: 20130410055744

Steps to reproduce:

Start firefox in private mode (firefox -private)
press ctrl-n to create a new private window


Actual results:

My session is restored(because that's the setting I have for firefox)


Expected results:

A new private window is created and I'm still in private mode (which goes along with the menus saying that Ctrl+N create a new private window)
Note that using the menu doesn't cause the bug to happen so it's likely a bad shortcut binding.
This bug is probably fixed in Nightly or Aurora because many PB issues have been fixed recently.
Could you confim, please: http://nightly.mozilla.org/
Component: Untriaged → Private Browsing
Flags: needinfo?(diaasami)
I have just tried it, the bug is still there in nightly, 23.0a1
Flags: needinfo?(diaasami)
This is sessionstore stuff.  Tim, do you have any idea what's happening here?
Flags: needinfo?(ttaubert)
I don't believe this is sessionstore stuff. The problem is that a NON-private browser window is opened when Ctrl-N is invoked from a private browsing window. If a new private browsing windows is opened as expected then it would not have triggered a session restore.

This behavior did not exist in FireFox 19.x because it's not possible to have both a private and non-private browser window open in a single session. This is now a problem with 20.x because FireFox now need to determine from which window (private or non-private) was the Ctrl-N invoked. There's no such thing as a private "session" anymore just private browsers/windows.
(In reply to comment #5)
> I don't believe this is sessionstore stuff. The problem is that a NON-private
> browser window is opened when Ctrl-N is invoked from a private browsing window.

That is intentional.  We don't want to change the meaning of keyboard shortcuts depending on the context.
If(In reply to :Ehsan Akhgari (needinfo? me!) from comment #6)
> That is intentional.  We don't want to change the meaning of keyboard
> shortcuts depending on the context.

So I suppose the way to ensure private-browsing window is opened is to use Ctrl-Shift-P; Ctrl-N will always open a regular non-private window (and restores session if that option is enabled). Hence this issue is expected behavior?
(In reply to comment #7)
> If(In reply to :Ehsan Akhgari (needinfo? me!) from comment #6)
> > That is intentional.  We don't want to change the meaning of keyboard
> > shortcuts depending on the context.
> 
> So I suppose the way to ensure private-browsing window is opened is to use
> Ctrl-Shift-P; Ctrl-N will always open a regular non-private window (and

Yes.

> restores session if that option is enabled). Hence this issue is expected
> behavior?

That I'm waiting for Tim to weigh in on.
(In reply to Diaa M. Sami from comment #0)
> Start firefox in private mode (firefox -private)

I know that per-window private browsing is fairly new stuff so you (and others) probably still imagine having a "private mode". You're starting Firefox with a single private window, not in private mode.

(In reply to Dave from comment #7)
> restores session if that option is enabled). Hence this issue is expected
> behavior?

Yes, I think that should be the expected behavior as we can't tell if you hit Ctrl+N by accident or because you actually wanted to start browsing outside of a private window. So we assume you wanted to open a non-private window and we restore your session so that you don't lose it.
Flags: needinfo?(ttaubert)
OK, so does that mean that we should mark this bug as invalid?
Yup. If anyone disagrees and has any specific improvements in mind, please open a new bug.
Status: UNCONFIRMED → RESOLVED
Closed: 7 years ago
Resolution: --- → INVALID
In this case then the menu is misleading because it says:
New Private Window Ctrl+N

And like I noted in the first bug report, when I use the menu the behavior is correct, a new private window is opened unlike the shortcut.
(In reply to Diaa M. Sami from comment #12)
> In this case then the menu is misleading because it says:
> New Private Window Ctrl+N

That's surprising.  Have you tested this in a clean profile with no extensions installed?  The correct shorcut key to be displayed there is Ctrl+Shift+P.
You need to log in before you can comment on or make changes to this bug.