If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Changes not published: "This document was modified while you were editing it."

REOPENED
Unassigned

Status

Mozilla Developer Network
Editing
--
major
REOPENED
5 years ago
4 years ago

People

(Reporter: MattN, Unassigned)

Tracking

Details

(URL)

Steps to reproduce:

I've tried to edit the following page to update the CSS transition syntax:
 https://developer.mozilla.org/en-US/docs/CSS/CSS_values_syntax

Actual results:

After clicking save, I got the error message "This document was modified while you were editing it." but the diff showed there were no changes.  I clicked Save again since there was no conflict and it just showed the same editing page and error message.  If I view the page, my change doesn't show up even though it appears in the history. I get the following error message:
 An update to this document is currently in progress. If the content below seems stale or if something is missing, please reload this page in a few minutes.

There are scripting messages on this page:

    UnknownError
    	
    Kumascript service failed unexpectedly: <class 'requests.exceptions.Timeout'>

Also, force reloading the page takes over 7 seconds and I sometimes get connection reset browser error messages.
Les, does this sound like it was caused by an intermittent KS issue?
Flags: needinfo?(lorchard)
(In reply to John Karahalis [:openjck] from comment #1)
> Les, does this sound like it was caused by an intermittent KS issue?

KumaScript cannot affect document editing. So, it can't have anything to do with the edit collision warning.

As for the rest, though, that page is very long and uses a large number of kumascript macros. It sounds like multiple simultaneous attempts to render the page were fired off, which can cause failures like this. I'll take a look at the page and see what's happening, but it's probably just a temporary problem
Flags: needinfo?(lorchard)
This looks like a dupe of bug 864347. Please reopen if I am mistaken.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 864347
No, this is not a duplicate of bug 864347. This one also involved a kumascript failure not mentioned in the other.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
You need to log in before you can comment on or make changes to this bug.