Last Comment Bug 866495 - JAWS virtual buffer becomes inaccessible frequently w/ JS enabled or disabled
: JAWS virtual buffer becomes inaccessible frequently w/ JS enabled or disabled
Status: RESOLVED FIXED
:
Product: Core
Classification: Components
Component: Disability Access APIs (show other bugs)
: 20 Branch
: x86 Windows 7
: -- normal (vote)
: mozilla23
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on: 865240
Blocks:
  Show dependency treegraph
 
Reported: 2013-04-28 01:16 PDT by Everett Zufelt
Modified: 2013-05-02 00:33 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Everett Zufelt 2013-04-28 01:16:42 PDT
User Agent: Mozilla/5.0 (Windows NT 6.1; rv:21.0) Gecko/20100101 Firefox/21.0
Build ID: 20130423212553

Steps to reproduce:

1. Firefox was automatically updated to 20.1 (also tried on 21 beta)
2. Tried to access sites I use commonly (myplanet.jira.com, github.com) both were accessed as an authenticated user. This happens on some other sites as well.
3. After viewing a few pages on the site JAWS would no longer read from virtual buffer.
4. Disabling virtual buffer I could tab through the site and JAWS would read focused item.
5. Turning virtual buffor back on JAWS would not read anything.
6. Refreshing virtual buffer did not help.
7. Starting Firefox with extensions disable did not help
8. Resetting Firefox did not help.
9. Trying with JS disabled seemed to lengthen duration on sites before problem appeared.


Actual results:

JAWS will not read virtual buffer.


Expected results:

JAWS should be able to read virtual buffer.
Comment 1 Everett Zufelt 2013-04-28 01:19:17 PDT
Using JAWS 13 or JAWS 14 on Windows 7 Professional. Problem only began to manifest after Firefox 20.1 update.
Comment 2 Marco Zehe (:MarcoZ) 2013-04-28 01:22:22 PDT
Tentatively, this is a dupe of bug 865240. Alex, do you agree?
Comment 3 alexander :surkov 2013-04-28 18:21:24 PDT
(In reply to Marco Zehe (:MarcoZ) from comment #2)
> Tentatively, this is a dupe of bug 865240. Alex, do you agree?

very similar
Comment 4 alexander :surkov 2013-05-02 00:33:16 PDT
fixed by bug 865240 (per bug 865240 comment #21)

Note You need to log in before you can comment on or make changes to this bug.