Camcorder crashes after recording finished

VERIFIED WORKSFORME

Status

Firefox OS
General
--
critical
VERIFIED WORKSFORME
5 years ago
5 years ago

People

(Reporter: diego, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [b2g-crash][CR 478814])

(Reporter)

Description

5 years ago
The crash is 100% reproducible on inari. Probably related to the layer refactoring.


#0  0x41d4bd36 in mozalloc_abort (msg=<value optimized out>)
    at /local/mnt/workspace/dwilson/master/gecko/memory/mozalloc/mozalloc_abort.cpp:30
#1  0x41d4bd4c in abort ()
    at /local/mnt/workspace/dwilson/master/gecko/memory/mozalloc/mozalloc_abort.cpp:39
#2  0x41d4bd4c in abort ()
    at /local/mnt/workspace/dwilson/master/gecko/memory/mozalloc/mozalloc_abort.cpp:39
Backtrace stopped: previous frame identical to this frame (corrupt stack?)
Unfortunately this stack only tells us that abort() was called.

Maybe try breaking on abort and __abort to hopefully get a better stack?

Any particular reason why you think that this might be related to the layer refactoring?
(Reporter)

Comment 2

5 years ago
(In reply to Benoit Jacob [:bjacob] from comment #1)
> Unfortunately this stack only tells us that abort() was called.
> 
> Maybe try breaking on abort and __abort to hopefully get a better stack?
>
 
Yeah, I know it's not that helpful :( This is what I get when gdb traps the exception.

> Any particular reason why you think that this might be related to the layer
> refactoring?

IIRC it didn't happen before https://hg.mozilla.org/mozilla-central/rev/ee5ca214e87c

Updated

5 years ago
Severity: normal → critical
Keywords: crash
Whiteboard: [b2g-crash]
I imagine this is the same crash as in the bug 866521, but let's see.
Diego, if you grab a patch from bug 866521, is it any better?  There are additional patches that may need to be picked up, bug 864017 depends on some, so it may take a bit to untangle it all.

Updated

5 years ago
Whiteboard: [b2g-crash] → [b2g-crash][CR 478814]
This is either a dupe of bug 866521 or bug 866952 or a combination of those, but either way, this works for me now on central, no other patches necessary.  Diego, if you can still get it to crash, please reopen.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

5 years ago
Works!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.