Comment Submit Form Should Submit To HTTPS

RESOLVED FIXED

Status

Websites
blog.mozilla.org
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: bensternthal, Unassigned)

Tracking

Details

(Reporter)

Description

5 years ago
Comment submit form on https pages submits to http endpoint.

Example:

https://blog.mozilla.org/tanvi/2013/04/10/mixed-content-blocking-enabled-in-firefox-23/#respond

Comment form submits to http://blog.mozilla.org/tanvi/wp-comments-post.php
(Reporter)

Comment 1

5 years ago
More info:

This might be due to the site url not actually being set to HTTPS. I do not have access to this setting however checking the permalinks setting for the web dev blog.. all the urls are HTTP not HTTPS
(Reporter)

Comment 2

5 years ago
This is resolved by changing the site url to https as described in the bug that now blocks this.

I tested and confirmed in production using Tanvi's blog.
Depends on: 866936
(Reporter)

Updated

5 years ago
No longer depends on: 866936
(Reporter)

Updated

5 years ago
Depends on: 899678
(Reporter)

Comment 3

5 years ago
So i think this resolved everywhere. I checked sub-blogs and all the ones I changed looked ok.

The main blog... I cant find any recent posts that have had comments enabled (maybe this is always turned off).
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.